aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLaurent Bigonville <bigon@bigon.be>2011-08-19 20:55:25 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2011-08-19 21:15:27 +0800
commit129f902925f603c163dc66757faf4d22632efe9e (patch)
tree803b049e619afcaaaf9718fa293f99c0cb728e05 /configure.ac
parent376c8299f4c69345fd783b20a8f2f4d8827551bb (diff)
downloadgsoc2013-empathy-129f902925f603c163dc66757faf4d22632efe9e.tar
gsoc2013-empathy-129f902925f603c163dc66757faf4d22632efe9e.tar.gz
gsoc2013-empathy-129f902925f603c163dc66757faf4d22632efe9e.tar.bz2
gsoc2013-empathy-129f902925f603c163dc66757faf4d22632efe9e.tar.lz
gsoc2013-empathy-129f902925f603c163dc66757faf4d22632efe9e.tar.xz
gsoc2013-empathy-129f902925f603c163dc66757faf4d22632efe9e.tar.zst
gsoc2013-empathy-129f902925f603c163dc66757faf4d22632efe9e.zip
Fix call-event.h detection
Correctly set the LDFLAGS from EMPATHY_LDFLAGS so AC_CHECK_HEADER can find call-event.h https://bugzilla.gnome.org/show_bug.cgi?id=656908
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0d48af677..f1522461e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -232,14 +232,17 @@ AC_ARG_ENABLE(call-logs,
if test "x$enable_call_logs" != "xno" ; then
SAVE_CFLAGS=$CFLAGS
SAVE_CPPFLAGS=$CPPFLAGS
+ SAVE_LDFLAGS=$LDFLAGS
CFLAGS="$CFLAGS $EMPATHY_CFLAGS"
CPPFLAGS="$CPPFLAGS $EMPATHY_CFLAGS"
+ LDFLAGS="$LDFLAGS $EMPATHY_LDFLAGS"
AC_CHECK_HEADER(telepathy-logger/call-event.h,
have_call_logs="yes", have_call_logs="no")
CFLAGS=$SAVE_CFLAGS
CPPFLAGS=$SAVE_CPPFLAGS
+ LDFLAGS=$SAVE_LDFLAGS
if test "x$have_call_logs" = "xyes"; then
AC_DEFINE(HAVE_CALL_LOGS, 1, [Define if you have call log support])