aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.co.uk>2012-07-16 20:51:51 +0800
committerXavier Claessens <xavier.claessens@collabora.co.uk>2012-07-23 20:34:17 +0800
commitfb37d92e195871b3e5a485d513bf6a7618a8eb60 (patch)
treed955e24ac4991fdd66daf03aa3c470532bad8749 /configure.ac
parent8671084e03f71a709b12ba6e813ae77f62cc0732 (diff)
downloadgsoc2013-empathy-fb37d92e195871b3e5a485d513bf6a7618a8eb60.tar
gsoc2013-empathy-fb37d92e195871b3e5a485d513bf6a7618a8eb60.tar.gz
gsoc2013-empathy-fb37d92e195871b3e5a485d513bf6a7618a8eb60.tar.bz2
gsoc2013-empathy-fb37d92e195871b3e5a485d513bf6a7618a8eb60.tar.lz
gsoc2013-empathy-fb37d92e195871b3e5a485d513bf6a7618a8eb60.tar.xz
gsoc2013-empathy-fb37d92e195871b3e5a485d513bf6a7618a8eb60.tar.zst
gsoc2013-empathy-fb37d92e195871b3e5a485d513bf6a7618a8eb60.zip
Add skeleton of an MC plugin to import Ubuntu Online Accounts
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b3ad14085..f4518ef46 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,6 +75,7 @@ NAUTILUS_SENDTO_REQUIRED=2.90.0
NETWORK_MANAGER_REQUIRED=0.7.0
CHAMPLAIN_REQUIRED=0.12.1
CHEESE_GTK_REQUIRED=3.4.0
+LIBACCOUNTS_REQUIRED=1.1
# Use --enable-maintainer-mode to disable deprecated symbols,
# disable single include and enable GSEAL. If this is not a released empathy,
@@ -229,6 +230,10 @@ PKG_CHECK_MODULES(EMPATHY_CALL,
AC_DEFINE(EMPATHY_GOA_PROVIDER, "org.gnome.OnlineAccounts",
[Name of provider for accounts imported from GOA])
+AC_DEFINE(EMPATHY_UOA_PROVIDER,
+ "im.telepathy.Account.Storage.UOA",
+ [Name of provider for accounts imported from libaccounts])
+
# -----------------------------------------------------------
# Enable debug
# -----------------------------------------------------------
@@ -506,6 +511,8 @@ if test "x$enable_ubuntu_online_accounts" != "xno"; then
PKG_CHECK_MODULES(UOA,
[
account-plugin
+ mission-control-plugins
+ libaccounts-glib >= $LIBACCOUNTS_REQUIRED
], have_uoa="yes", have_uoa="no")
else
have_uoa=no
@@ -552,6 +559,8 @@ AC_CONFIG_FILES([
src/Makefile
nautilus-sendto-plugin/Makefile
goa-mc-plugin/Makefile
+ ubuntu-online-accounts/Makefile
+ ubuntu-online-accounts/mc-plugin/Makefile
help/Makefile
tests/Makefile
tests/interactive/Makefile