aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-02-21 22:13:17 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-02-21 23:02:29 +0800
commitb48a8176d050de2d03bed6c5f00b451f3ca5c750 (patch)
tree7a1c40708fbf6126e0566553006de8b016f780a2 /configure.ac
parent988a99a9a54a20fff1846275f98a0c3b3c4c3469 (diff)
downloadgsoc2013-empathy-b48a8176d050de2d03bed6c5f00b451f3ca5c750.tar
gsoc2013-empathy-b48a8176d050de2d03bed6c5f00b451f3ca5c750.tar.gz
gsoc2013-empathy-b48a8176d050de2d03bed6c5f00b451f3ca5c750.tar.bz2
gsoc2013-empathy-b48a8176d050de2d03bed6c5f00b451f3ca5c750.tar.lz
gsoc2013-empathy-b48a8176d050de2d03bed6c5f00b451f3ca5c750.tar.xz
gsoc2013-empathy-b48a8176d050de2d03bed6c5f00b451f3ca5c750.tar.zst
gsoc2013-empathy-b48a8176d050de2d03bed6c5f00b451f3ca5c750.zip
always build empathy-call
https://bugzilla.gnome.org/show_bug.cgi?id=629902
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 9 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index 5480adb00..504a575e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -204,42 +204,19 @@ PKG_CHECK_MODULES(EMPATHY_AV,
telepathy-farsight >= $TELEPATHY_FARSIGHT_REQUIRED
])
+PKG_CHECK_MODULES(EMPATHY_CALL,
+[
+ farstream-0.1
+ telepathy-farstream >= $TELEPATHY_FARSTREAM_REQUIRED
+ clutter-1.0 >= $CLUTTER_REQUIRED
+ clutter-gtk-1.0
+ clutter-gst-1.0
+])
+
AC_DEFINE(EMPATHY_GOA_PROVIDER, "org.gnome.OnlineAccounts",
[Name of provider for accounts imported from GOA])
# -----------------------------------------------------------
-# Call interface
-# -----------------------------------------------------------
-AC_ARG_ENABLE(call,
- AS_HELP_STRING([--enable-call=@<:@no/yes/auto@:>@],
- [build with Call interface support]),,
- [enable_call=auto])
-if test "x$enable_call" != "xno" ; then
- PKG_CHECK_MODULES(EMPATHY_CALL,
- [
- farstream-0.1
- telepathy-farstream >= $TELEPATHY_FARSTREAM_REQUIRED
- clutter-1.0 >= $CLUTTER_REQUIRED
- clutter-gtk-1.0
- clutter-gst-1.0
- ], have_call="yes", have_call="no" )
-
- if test "x$have_call" = "xyes"; then
- AC_DEFINE(HAVE_CALL, 1, [Define if you have Call channel support])
- fi
-else
- have_call=no
-fi
-
-if test "x$enable_call" = "xyes" -a "x$have_call" != "xyes"; then
- AC_MSG_ERROR([Could not find Call handler dependencies:
-
-$EMPATHY_CALL_PKG_ERRORS])
-fi
-AM_CONDITIONAL(HAVE_CALL, test "x$have_call" = "xyes")
-
-
-# -----------------------------------------------------------
# Call support in tp-logger
# -----------------------------------------------------------
AC_ARG_ENABLE(call-logs,
@@ -697,6 +674,5 @@ Configure summary:
Nautilus-sendto plugin......: ${have_nst}
GOA MC plugin...............: ${have_goa}
Salut E-D-S support.........: ${with_eds}
- Exp. Call channel handler...: ${have_call}
Exp. Call log support.......: ${have_call_logs}
"