aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRaluca Elena Podiuc <ralucaelena1985@gmail.com>2011-04-12 03:34:01 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2011-05-26 15:08:10 +0800
commit87118ba7e4c1a07765ccb762b9ccd603b5facc7b (patch)
treeb0c26599c97f839ee6a6c86f45d5719aabed3c2c /configure.ac
parenta6a4c117c17659134df600c9b96f8cceb07f44ef (diff)
downloadgsoc2013-empathy-87118ba7e4c1a07765ccb762b9ccd603b5facc7b.tar
gsoc2013-empathy-87118ba7e4c1a07765ccb762b9ccd603b5facc7b.tar.gz
gsoc2013-empathy-87118ba7e4c1a07765ccb762b9ccd603b5facc7b.tar.bz2
gsoc2013-empathy-87118ba7e4c1a07765ccb762b9ccd603b5facc7b.tar.lz
gsoc2013-empathy-87118ba7e4c1a07765ccb762b9ccd603b5facc7b.tar.xz
gsoc2013-empathy-87118ba7e4c1a07765ccb762b9ccd603b5facc7b.tar.zst
gsoc2013-empathy-87118ba7e4c1a07765ccb762b9ccd603b5facc7b.zip
libempathy-gtk: add dependency on libcheese
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9e0500894..8b8eef699 100644
--- a/configure.ac
+++ b/configure.ac
@@ -464,6 +464,25 @@ AM_CONDITIONAL(HAVE_CONTROL_CENTER_EMBEDDING, test "x$have_control_center_embedd
AC_SUBST(CONTROL_CENTER_EMBEDDING_CFLAGS)
AC_SUBST(CONTROL_CENTER_EMBEDDING_LIBS)
+# Optional dependency for avatar selection
+AC_ARG_WITH([cheese],
+ AS_HELP_STRING([--with-cheese], [enable cheese webcam support]),,
+ with_cheese=auto)
+
+if test x"$with_cheese" != x"no" ; then
+ PKG_CHECK_MODULES(CHEESE, gstreamer-0.10 cheese-gtk >= 2.91.91.1, [have_cheese=yes], [have_cheese=no])
+ if test x${have_cheese} = xyes; then
+ AC_DEFINE(HAVE_CHEESE, 1, [Define to 1 to enable cheese webcam support])
+ fi
+ if test x${with_cheese} = xyes && test x${have_cheese} = xno; then
+ AC_MSG_ERROR([Cheese configured but not found])
+ fi
+else
+ have_cheese=no
+fi
+AM_CONDITIONAL(BUILD_CHEESE, test x${have_cheese} = xyes)
+
+
# -----------------------------------------------------------
# Coding style checks
# -----------------------------------------------------------
@@ -509,6 +528,7 @@ Configure summary:
Adium themes (Webkit).......: ${have_webkit}
Meego widgets ..............: ${have_meego}
Control center embedding....: ${have_control_center_embedding}
+ Cheese webcam support ......: ${have_cheese}
Connectivity:
NetworkManager integration..: ${have_nm}