aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2008-12-11 22:23:56 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2008-12-11 22:23:56 +0800
commitb4fe6c835d5b8c0b1ad7787a780c7686999d2e3a (patch)
tree6df4fb7236113abdcbc42c81c1c5599f63f1441c /configure.ac
parent9ab8eae5172e12fde05d488c89dcb5dbe06fb0d4 (diff)
downloadgsoc2013-empathy-b4fe6c835d5b8c0b1ad7787a780c7686999d2e3a.tar
gsoc2013-empathy-b4fe6c835d5b8c0b1ad7787a780c7686999d2e3a.tar.gz
gsoc2013-empathy-b4fe6c835d5b8c0b1ad7787a780c7686999d2e3a.tar.bz2
gsoc2013-empathy-b4fe6c835d5b8c0b1ad7787a780c7686999d2e3a.tar.lz
gsoc2013-empathy-b4fe6c835d5b8c0b1ad7787a780c7686999d2e3a.tar.xz
gsoc2013-empathy-b4fe6c835d5b8c0b1ad7787a780c7686999d2e3a.tar.zst
gsoc2013-empathy-b4fe6c835d5b8c0b1ad7787a780c7686999d2e3a.zip
Add commented out defines to disable single include for GLib, GDK and GTK.
svn path=/trunk/; revision=1958
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 11 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index aebf55628..18cfbb694 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,11 +35,16 @@ MISSION_CONTROL_REQUIRED=4.61
ENCHANT_REQUIRED=1.2.0
ISO_CODES_REQUIRED=0.35
-# Uncomment that to build without deprecated symbols
-# AC_DEFINE(G_DISABLE_DEPRECATED, 1, [Disable deprecated GLib symbols])
-# AC_DEFINE(GDK_PIXBUF_DISABLE_DEPRECATED, 1, [Disable deprecated GDK pixbuf symbols])
-# AC_DEFINE(GDK_DISABLE_DEPRECATED, 1, [Disable deprecated GDK symbols])
-# AC_DEFINE(GTK_DISABLE_DEPRECATED, 1, [Disable deprecated GTK symbols])
+# Uncomment that to build with deprecated symbols disabled
+#AC_DEFINE(G_DISABLE_DEPRECATED, [], [Disable deprecated GLib symbols])
+#AC_DEFINE(GDK_PIXBUF_DISABLE_DEPRECATED, [], [Disable deprecated GDK pixbuf symbols])
+#AC_DEFINE(GDK_DISABLE_DEPRECATED, [], [Disable deprecated GDK symbols])
+#AC_DEFINE(GTK_DISABLE_DEPRECATED, [], [Disable deprecated GTK symbols])
+
+# Uncomment that to build with single include disabled
+#AC_DEFINE(G_DISABLE_SINGLE_INCLUDES, [], [Disable single includes for GLib])
+#AC_DEFINE(GDK_PIXBUF_DISABLE_SINGLE_INCLUDES, [], [Disable single includes for GDK pixbuf])
+#AC_DEFINE(GTK_DISABLE_SINGLE_INCLUDES, [], [Disable single includes for GTK])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADERS([config.h])
@@ -146,7 +151,7 @@ if test "x$enable_spell" != "xno"; then
if $PKG_CONFIG --variable=domains iso-codes | grep 639 > /dev/null && \
$PKG_CONFIG --variable=domains iso-codes | grep 3166 > /dev/null ; then
AC_DEFINE_UNQUOTED(ISO_CODES_PREFIX, ["`$PKG_CONFIG --variable=prefix iso-codes`"], [ISO codes prefix])
- AC_DEFINE(HAVE_ENCHANT, 1, [Define if you have libenchant])
+ AC_DEFINE(HAVE_ENCHANT, [], [Define if you have libenchant])
result=yes
else
result=no