aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPhilip Withnall <philip.withnall@collabora.co.uk>2010-09-07 17:46:12 +0800
committerPhilip Withnall <philip.withnall@collabora.co.uk>2010-09-07 17:50:47 +0800
commit290a4853102e645d76318e8e09ef45420a6559bc (patch)
treef35da604f566a7e148709707c4a3b863e49066b5 /configure.ac
parent0b6ef5b5eac2633e4c7660c58b2bb6f412dd1a2a (diff)
downloadgsoc2013-empathy-290a4853102e645d76318e8e09ef45420a6559bc.tar
gsoc2013-empathy-290a4853102e645d76318e8e09ef45420a6559bc.tar.gz
gsoc2013-empathy-290a4853102e645d76318e8e09ef45420a6559bc.tar.bz2
gsoc2013-empathy-290a4853102e645d76318e8e09ef45420a6559bc.tar.lz
gsoc2013-empathy-290a4853102e645d76318e8e09ef45420a6559bc.tar.xz
gsoc2013-empathy-290a4853102e645d76318e8e09ef45420a6559bc.tar.zst
gsoc2013-empathy-290a4853102e645d76318e8e09ef45420a6559bc.zip
Remove calls to gtk_dialog_set_has_separator() if building against GTK+ 3
gtk_dialog_set_has_separator() has been removed in GTK+ 3, but can't be removed (or the property's default value changed) in GTK+ 2 without breaking API. This adds a wrapper macro to keep the calls when building against GTK+ 2, and remove them when building against GTK+ 3.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 500380969..93391dff9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -205,6 +205,8 @@ if test "x$have_gtk3" == "xyes"; then
PKG_CHECK_MODULES(LIBNOTIFY, libnotify >= $LIBNOTIFY_REQUIRED_GTK3)
PKG_CHECK_MODULES(UNIQUE, unique-3.0 >= $UNIQUE_REQUIRED)
PKG_CHECK_MODULES(GCR, gcr-3 >= $KEYRING_REQUIRED)
+
+ AC_DEFINE(HAVE_GTK3, 1, [Define if we're compiling against GTK+ 3])
else
PKG_CHECK_MODULES(GTK, gtk+-2.0 >= $GTK_REQUIRED)