aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2010-07-08 16:36:16 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2010-07-08 17:40:31 +0800
commit757c4d6c3e3a1872588387bfd49f473ce444b3cf (patch)
tree826624b6dcfddcf148f5bd9e14ddee2237c2f80a /configure.ac
parent457808007540c9d7ab0f6b29f2d8e643d46eb8b4 (diff)
downloadgsoc2013-empathy-757c4d6c3e3a1872588387bfd49f473ce444b3cf.tar
gsoc2013-empathy-757c4d6c3e3a1872588387bfd49f473ce444b3cf.tar.gz
gsoc2013-empathy-757c4d6c3e3a1872588387bfd49f473ce444b3cf.tar.bz2
gsoc2013-empathy-757c4d6c3e3a1872588387bfd49f473ce444b3cf.tar.lz
gsoc2013-empathy-757c4d6c3e3a1872588387bfd49f473ce444b3cf.tar.xz
gsoc2013-empathy-757c4d6c3e3a1872588387bfd49f473ce444b3cf.tar.zst
gsoc2013-empathy-757c4d6c3e3a1872588387bfd49f473ce444b3cf.zip
Check for webkitgtk-3.0 when building with GTK3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2656c9edd..175b7669f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -284,10 +284,14 @@ AC_ARG_ENABLE(webkit,
enable_webkit=auto)
if test "x$enable_webkit" != "xno"; then
- PKG_CHECK_MODULES(WEBKIT,
- [
- webkit-1.0 >= $WEBKIT_REQUIRED
- ], have_webkit="yes", have_webkit="no")
+
+ if test "x$enable_gtk3" == "xno"; then
+ PKG_CHECK_MODULES(WEBKIT, [webkit-1.0 >= $WEBKIT_REQUIRED],
+ have_webkit="yes", have_webkit="no")
+ else
+ PKG_CHECK_MODULES(WEBKIT, [webkitgtk-3.0 >= $WEBKIT_REQUIRED],
+ have_webkit="yes", have_webkit="no")
+ fi
if test "x$have_webkit" = "xyes"; then
AC_DEFINE(HAVE_WEBKIT, 1, [Define if you have libwebkitgtk])