aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJonny Lamb <jonnylamb@gnome.org>2009-10-20 19:59:15 +0800
committerJonny Lamb <jonnylamb@gnome.org>2009-10-20 20:10:28 +0800
commit6496713f0997ab90e7ee686819640b22b4911aea (patch)
treec18874181bb0cf1a8abaafa0a946273df5b684b1 /configure.ac
parent90469882929d06151352d3d8e8b0e6a1f5229905 (diff)
downloadgsoc2013-empathy-6496713f0997ab90e7ee686819640b22b4911aea.tar
gsoc2013-empathy-6496713f0997ab90e7ee686819640b22b4911aea.tar.gz
gsoc2013-empathy-6496713f0997ab90e7ee686819640b22b4911aea.tar.bz2
gsoc2013-empathy-6496713f0997ab90e7ee686819640b22b4911aea.tar.lz
gsoc2013-empathy-6496713f0997ab90e7ee686819640b22b4911aea.tar.xz
gsoc2013-empathy-6496713f0997ab90e7ee686819640b22b4911aea.tar.zst
gsoc2013-empathy-6496713f0997ab90e7ee686819640b22b4911aea.zip
Remove python bindings. (Closes bug #599039)
Signed-off-by: Jonny Lamb <jonnylamb@gnome.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 0 insertions, 39 deletions
diff --git a/configure.ac b/configure.ac
index f98d937ce..facdd7ce1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -456,41 +456,6 @@ fi
AM_CONDITIONAL(HAVE_TESTS, test "x$have_check" = "xyes")
# -----------------------------------------------------------
-# Python Bindings
-# -----------------------------------------------------------
-AC_ARG_ENABLE(python,
- AS_HELP_STRING([--enable-python=@<:@no/yes/auto@:>@],
- [build python bindings to libempathy and libempathy-gtk]), ,
- enable_python=auto)
-
-if test "x$enable_python" != "xno"; then
- PKG_CHECK_MODULES(PYTHON_BINDING,
- [
- pygtk-2.0,
- glib-2.0 >= $GLIB_REQUIRED
- gobject-2.0
- gconf-2.0 >= $GCONF_REQUIRED
- libxml-2.0
- gtk+-2.0 >= $GTK_REQUIRED
- gstreamer-0.10
- gstreamer-interfaces-0.10
- telepathy-farsight
- ], have_python="yes", have_python="no")
- if test "x$have_python" = "xyes" ; then
- AM_CHECK_PYTHON_HEADERS(,have_python="no")
- AC_CHECK_PROGS([PYGOBJECTCODEGEN], [pygobject-codegen-2.0 pygtk-codegen-2.0])
- fi
-else
- have_python=no
-fi
-
-if test "x$enable_python" = "xyes" -a "x$have_python" != "xyes"; then
- AC_MSG_ERROR([Couldn't find python.])
-fi
-
-AM_CONDITIONAL(HAVE_PYTHON, test "x$have_python" = "xyes")
-
-# -----------------------------------------------------------
# Coding style checks
# -----------------------------------------------------------
AC_ARG_ENABLE(coding-style-checks,
@@ -528,9 +493,6 @@ AC_OUTPUT([
docs/libempathy-gtk/Makefile
docs/libempathy-gtk/version.xml
help/Makefile
- python/Makefile
- python/pyempathy/Makefile
- python/pyempathygtk/Makefile
tests/Makefile
tests/xml/Makefile
tools/Makefile
@@ -561,7 +523,6 @@ Configure summary:
Extras:
Documentation...............: ${enable_gtk_doc}
- Python bindings.............: ${have_python}
Megaphone applet............: ${have_megaphone}
Nothere applet..............: ${have_nothere}
Nautilus-sendto plugin......: ${have_nst}