aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJonny Lamb <jonnylamb@gnome.org>2009-10-20 20:07:52 +0800
committerJonny Lamb <jonnylamb@gnome.org>2009-10-20 20:08:55 +0800
commitda500948288ec5e9e675502151e5305bdf063592 (patch)
tree497aec6f8fa6294218a95b3f4461a5e756ae61e1 /configure.ac
parent90469882929d06151352d3d8e8b0e6a1f5229905 (diff)
downloadgsoc2013-empathy-da500948288ec5e9e675502151e5305bdf063592.tar
gsoc2013-empathy-da500948288ec5e9e675502151e5305bdf063592.tar.gz
gsoc2013-empathy-da500948288ec5e9e675502151e5305bdf063592.tar.bz2
gsoc2013-empathy-da500948288ec5e9e675502151e5305bdf063592.tar.lz
gsoc2013-empathy-da500948288ec5e9e675502151e5305bdf063592.tar.xz
gsoc2013-empathy-da500948288ec5e9e675502151e5305bdf063592.tar.zst
gsoc2013-empathy-da500948288ec5e9e675502151e5305bdf063592.zip
Remove the panel applets. (Closes bug #599042)
Signed-off-by: Jonny Lamb <jonnylamb@gnome.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac62
1 files changed, 0 insertions, 62 deletions
diff --git a/configure.ac b/configure.ac
index f98d937ce..502c55012 100644
--- a/configure.ac
+++ b/configure.ac
@@ -356,33 +356,6 @@ AC_SUBST(MOBLIN_CFLAGS)
AC_SUBST(MOBLIN_LIBS)
# -----------------------------------------------------------
-# Megaphone
-# -----------------------------------------------------------
-AC_ARG_ENABLE(megaphone,
- AS_HELP_STRING([--enable-megaphone=@<:@no/yes/auto@:>@],
- [build megaphone applet]), ,
- enable_megaphone=auto)
-
-if test "x$enable_megaphone" != "xno"; then
- PKG_CHECK_MODULES(MEGAPHONE,
- [
- libpanelapplet-2.0 >= $LIBPANELAPPLET_REQUIRED
- glib-2.0 >= $GLIB_REQUIRED
- gtk+-2.0 >= $GTK_REQUIRED
- gconf-2.0 >= $GCONF_REQUIRED
- telepathy-glib >= $TELEPATHY_GLIB_REQUIRED
- ], have_megaphone="yes", have_megaphone="no")
-else
- have_megaphone=no
-fi
-
-if test "x$enable_megaphone" = "xyes" -a "x$have_megaphone" != "xyes"; then
- AC_MSG_ERROR([Couldn't find megaphone dependencies.])
-fi
-
-AM_CONDITIONAL(HAVE_MEGAPHONE, test "x$have_megaphone" = "xyes")
-
-# -----------------------------------------------------------
# nautilus-sendto
# -----------------------------------------------------------
AC_ARG_ENABLE(nautilus-sendto,
@@ -406,33 +379,6 @@ fi
AM_CONDITIONAL(HAVE_NST, test "x$have_nst" = "xyes")
# -----------------------------------------------------------
-# Nothere
-# -----------------------------------------------------------
-AC_ARG_ENABLE(nothere,
- AS_HELP_STRING([--enable-nothere=@<:@no/yes/auto@:>@],
- [build nothere applet]), ,
- enable_nothere=auto)
-
-if test "x$enable_nothere" != "xno"; then
- PKG_CHECK_MODULES(NOTHERE,
- [
- libpanelapplet-2.0 >= $LIBPANELAPPLET_REQUIRED
- glib-2.0 >= $GLIB_REQUIRED
- gtk+-2.0 >= $GTK_REQUIRED
- gconf-2.0 >= $GCONF_REQUIRED
- telepathy-glib >= $TELEPATHY_GLIB_REQUIRED
- ], have_nothere="yes", have_nothere="no")
-else
- have_nothere=no
-fi
-
-if test "x$enable_nothere" = "xyes" -a "x$have_nothere" != "xyes"; then
- AC_MSG_ERROR([Couldn't find nothere dependencies.])
-fi
-
-AM_CONDITIONAL(HAVE_NOTHERE, test "x$have_nothere" = "xyes")
-
-# -----------------------------------------------------------
# Tests
# -----------------------------------------------------------
AC_ARG_ENABLE(tests,
@@ -515,13 +461,7 @@ AC_OUTPUT([
libempathy-gtk/Makefile
libempathy-gtk/libempathy-gtk.pc
src/Makefile
- megaphone/Makefile
- megaphone/src/Makefile
- megaphone/data/Makefile
nautilus-sendto-plugin/Makefile
- nothere/Makefile
- nothere/src/Makefile
- nothere/data/Makefile
docs/Makefile
docs/libempathy/Makefile
docs/libempathy/version.xml
@@ -562,7 +502,5 @@ Configure summary:
Extras:
Documentation...............: ${enable_gtk_doc}
Python bindings.............: ${have_python}
- Megaphone applet............: ${have_megaphone}
- Nothere applet..............: ${have_nothere}
Nautilus-sendto plugin......: ${have_nst}
"