aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2008-04-09 20:15:19 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2008-04-09 20:15:19 +0800
commit9496ad05eb86ce5793030e47e88aa01dff48cb62 (patch)
tree723b728d35f75ae38082834e040fae822a127432 /configure.ac
parent881aadbd2abd16a1cc3d64b267cd06b08b629a2d (diff)
downloadgsoc2013-empathy-9496ad05eb86ce5793030e47e88aa01dff48cb62.tar
gsoc2013-empathy-9496ad05eb86ce5793030e47e88aa01dff48cb62.tar.gz
gsoc2013-empathy-9496ad05eb86ce5793030e47e88aa01dff48cb62.tar.bz2
gsoc2013-empathy-9496ad05eb86ce5793030e47e88aa01dff48cb62.tar.lz
gsoc2013-empathy-9496ad05eb86ce5793030e47e88aa01dff48cb62.tar.xz
gsoc2013-empathy-9496ad05eb86ce5793030e47e88aa01dff48cb62.tar.zst
gsoc2013-empathy-9496ad05eb86ce5793030e47e88aa01dff48cb62.zip
Empathy should not require python-config. Fixes bug #525562 (Frederic Peters).
svn path=/trunk/; revision=880
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4b38c595c..ed8a826d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,7 +68,7 @@ AC_CHECK_PROGS([XSLTPROC], [xsltproc])
if test -z "$XSLTPROC"; then
AC_MSG_ERROR([xsltproc (from libxslt) is required])
fi
-AC_CHECK_PROGS([PYTHON], [python2.3 python2.4 python2.5 python])
+AC_CHECK_PROGS([PYTHON], [python python2.3 python2.4 python2.5])
if test -z "$PYTHON"; then
AC_MSG_ERROR([Python is required])
fi
@@ -268,6 +268,9 @@ if test "x$enable_python" != "xno"; then
gtk+-2.0 >= $GTK_REQUIRED
libglade-2.0 >= $LIBGLADE_REQUIRED
], have_python="yes", have_python="no")
+ if test "x$have_python" = "xyes" ; then
+ AM_CHECK_PYTHON_HEADERS(,have_python="no")
+ fi
fi
else
have_python=no