aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorxclaesse <xclaesse@4ee84921-47dd-4033-b63a-18d7a039a3e4>2007-09-21 20:24:24 +0800
committerxclaesse <xclaesse@4ee84921-47dd-4033-b63a-18d7a039a3e4>2007-09-21 20:24:24 +0800
commitb837536e621e863a59c251d5528d7db16fcc96e4 (patch)
tree01e1aca50b42a38943ae09f8fd327aba2f8af118 /configure.ac
parente807ad57a07145b79466acdc53a5658126aa1843 (diff)
downloadgsoc2013-empathy-b837536e621e863a59c251d5528d7db16fcc96e4.tar
gsoc2013-empathy-b837536e621e863a59c251d5528d7db16fcc96e4.tar.gz
gsoc2013-empathy-b837536e621e863a59c251d5528d7db16fcc96e4.tar.bz2
gsoc2013-empathy-b837536e621e863a59c251d5528d7db16fcc96e4.tar.lz
gsoc2013-empathy-b837536e621e863a59c251d5528d7db16fcc96e4.tar.xz
gsoc2013-empathy-b837536e621e863a59c251d5528d7db16fcc96e4.tar.zst
gsoc2013-empathy-b837536e621e863a59c251d5528d7db16fcc96e4.zip
2007-09-21 Xavier Claessens <xclaesse@gmail.com>
* libempathy/empathy-tp-contact-list.c: Fix warnings when finalizing. * tests/contact-manager.c: * tests/Makefile.am: * configure.ac: * Makefile.am: Add a test program to track leaks. git-svn-id: svn+ssh://svn.gnome.org/svn/empathy/trunk@304 4ee84921-47dd-4033-b63a-18d7a039a3e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a3e865f28..bade8bb30 100644
--- a/configure.ac
+++ b/configure.ac
@@ -205,6 +205,16 @@ fi
AM_CONDITIONAL(HAVE_NOTHERE, test "x$have_nothere" = "xyes")
dnl -----------------------------------------------------------
+dnl Tests
+dnl -----------------------------------------------------------
+AC_ARG_ENABLE(tests,
+ AS_HELP_STRING([--enable-tests=@<:@no/yes@:>@],
+ [build tests]), ,
+ enable_tests=no)
+
+AM_CONDITIONAL(HAVE_TESTS, test "x$enable_tests" = "xyes")
+
+dnl -----------------------------------------------------------
dnl Python Bindings
dnl -----------------------------------------------------------
AC_ARG_ENABLE(python,
@@ -271,4 +281,5 @@ AC_OUTPUT([
python/Makefile
python/pyempathy/Makefile
python/pyempathygtk/Makefile
+ tests/Makefile
])