aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorxclaesse <xclaesse@4ee84921-47dd-4033-b63a-18d7a039a3e4>2008-02-26 21:31:02 +0800
committerxclaesse <xclaesse@4ee84921-47dd-4033-b63a-18d7a039a3e4>2008-02-26 21:31:02 +0800
commitc20c59c6cfefa0e7210282e19a6fc33bd65c95f7 (patch)
tree4ba009a19d6f3254acb8d91be788d49a7e259fc2 /configure.ac
parent3c9d522f2784b634077f09ea4e753904ad21524e (diff)
downloadgsoc2013-empathy-c20c59c6cfefa0e7210282e19a6fc33bd65c95f7.tar
gsoc2013-empathy-c20c59c6cfefa0e7210282e19a6fc33bd65c95f7.tar.gz
gsoc2013-empathy-c20c59c6cfefa0e7210282e19a6fc33bd65c95f7.tar.bz2
gsoc2013-empathy-c20c59c6cfefa0e7210282e19a6fc33bd65c95f7.tar.lz
gsoc2013-empathy-c20c59c6cfefa0e7210282e19a6fc33bd65c95f7.tar.xz
gsoc2013-empathy-c20c59c6cfefa0e7210282e19a6fc33bd65c95f7.tar.zst
gsoc2013-empathy-c20c59c6cfefa0e7210282e19a6fc33bd65c95f7.zip
Import tools from telepathy-glib 0.7.3 and build a static libemp-extensions.la.
Link that library into libempathy (it's not actually used for anything at this point). Extensions currently built: ChannelHandler and StreamEngine. The namespacing convention used is emp_*, Emp*, EMP_* so it won't be included in the library ABI. git-svn-id: svn+ssh://svn.gnome.org/svn/empathy/trunk@663 4ee84921-47dd-4033-b63a-18d7a039a3e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ac012243a..4d26cae4e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,7 +31,7 @@ GCONF_REQUIRED=1.2.0
LIBGLADE_REQUIRED=2.0.0
LIBPANELAPPLET_REQUIRED=2.10.0
TELEPATHY_REQUIRED=0.3.1
-TELEPATHY_GLIB_REQUIRED=0.7.0
+TELEPATHY_GLIB_REQUIRED=0.7.3
MISSION_CONTROL_REQUIRED=4.53
# Uncomment that to build without deprecated symbols
@@ -52,6 +52,7 @@ AC_ISC_POSIX
AC_PROG_CC
AC_HEADER_STDC
AM_PROG_LIBTOOL
+AM_PROG_MKDIR_P
AM_PATH_GLIB_2_0
AC_PATH_XTRA
IT_PROG_INTLTOOL([0.35.0])
@@ -63,6 +64,15 @@ AM_GCONF_SOURCE_2
GLIB_GENMARSHAL=`$PKG_CONFIG glib-2.0 --variable=glib_genmarshal`
AC_SUBST(GLIB_GENMARSHAL)
+AC_CHECK_PROGS([XSLTPROC], [xsltproc])
+if test -z "$XSLTPROC"; then
+ AC_MSG_ERROR([xsltproc (from libxslt) is required])
+fi
+AC_CHECK_PROGS([PYTHON], [python2.3 python2.4 python2.5 python])
+if test -z "$PYTHON"; then
+ AC_MSG_ERROR([Python is required])
+fi
+
EMPATHY_ARG_VALGRIND
# -----------------------------------------------------------
@@ -300,6 +310,7 @@ AC_OUTPUT([
data/Makefile
data/empathy.desktop.in
data/icons/Makefile
+ extensions/Makefile
po/Makefile.in
libempathy/Makefile
libempathy/libempathy.pc
@@ -321,4 +332,5 @@ AC_OUTPUT([
python/pyempathy/Makefile
python/pyempathygtk/Makefile
tests/Makefile
+ tools/Makefile
])