aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorxclaesse <xclaesse@4ee84921-47dd-4033-b63a-18d7a039a3e4>2007-09-29 20:08:45 +0800
committerxclaesse <xclaesse@4ee84921-47dd-4033-b63a-18d7a039a3e4>2007-09-29 20:08:45 +0800
commita3606fd8eddc31203af6863b2811a80f2acf0ba2 (patch)
tree9036ec7c855079e59ec6b67128ee37134bb79abf /configure.ac
parent7acb27e9957ccac908dea7d650863a0a848b5663 (diff)
downloadgsoc2013-empathy-a3606fd8eddc31203af6863b2811a80f2acf0ba2.tar
gsoc2013-empathy-a3606fd8eddc31203af6863b2811a80f2acf0ba2.tar.gz
gsoc2013-empathy-a3606fd8eddc31203af6863b2811a80f2acf0ba2.tar.bz2
gsoc2013-empathy-a3606fd8eddc31203af6863b2811a80f2acf0ba2.tar.lz
gsoc2013-empathy-a3606fd8eddc31203af6863b2811a80f2acf0ba2.tar.xz
gsoc2013-empathy-a3606fd8eddc31203af6863b2811a80f2acf0ba2.tar.zst
gsoc2013-empathy-a3606fd8eddc31203af6863b2811a80f2acf0ba2.zip
2007-09-29 Xavier Claessens <xclaesse@gmail.com>
* libempathy-gtk/empathy-call-window.c: * libempathy-gtk/empathy-call-window.h: * libempathy-gtk/empathy-contact-list-view.c: * libempathy-gtk/empathy-call-window.glade: * libempathy-gtk/Makefile.am: * libempathy-gtk/empathy-chat-window.c: * src/empathy-call-chandler.c: * src/empathy-call.chandler: * src/org.gnome.Empathy.Call.service.in: * src/Makefile.am: * libempathy/empathy-utils.c: * libempathy/empathy-utils.h: * libempathy/empathy-tp-call.c: * libempathy/empathy-tp-call.h: * libempathy/Makefile.am: * libempathy/tp-stream-engine.xml: * configure.ac: * doc/libempathy-gtk/libempathy-gtk-docs.sgml: * doc/libempathy/libempathy.types: * doc/libempathy/libempathy-docs.sgml: * doc/libempathy/Makefile.am: * doc/libempathy/tmpl/empathy-utils.sgml: Initial Voice+Video support Fixes bug #468204 (Elliot Fairweather, Xavier Claessens). git-svn-id: svn+ssh://svn.gnome.org/svn/empathy/trunk@339 4ee84921-47dd-4033-b63a-18d7a039a3e4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f3fe46945..9fd3a1c36 100644
--- a/configure.ac
+++ b/configure.ac
@@ -251,6 +251,20 @@ fi
AM_CONDITIONAL(HAVE_PYTHON, test "x$have_python" = "xyes")
dnl -----------------------------------------------------------
+dnl VoIP support
+dnl -----------------------------------------------------------
+AC_ARG_ENABLE(voip,
+ AS_HELP_STRING([--enable-voip=@<:@no/yes@:>@],
+ [Add support for Voice and Video call]), ,
+ enable_voip=no)
+
+if test "x$enable_voip" = "xyes"; then
+ AC_DEFINE(HAVE_VOIP, 1, [Define if we have voip])
+fi
+
+AM_CONDITIONAL(HAVE_VOIP, test "x$enable_voip" = "xyes")
+
+dnl -----------------------------------------------------------
AC_OUTPUT([
Makefile
@@ -273,7 +287,8 @@ AC_OUTPUT([
megaphone/data/Makefile
nothere/Makefile
nothere/src/Makefile
- nothere/data/Makefile doc/Makefile
+ nothere/data/Makefile
+ doc/Makefile
doc/libempathy/Makefile
doc/libempathy-gtk/Makefile
python/Makefile