aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@gmail.com>2007-06-10 17:18:19 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-06-10 17:18:19 +0800
commit3481670915dcd593d7156bda1aec970a42890e0b (patch)
treee32f211bc48bf2a97674077a07d2eed6a232b9bb /configure.ac
parent7011153ce3fa6807677e1df874389085fd5f0971 (diff)
downloadgsoc2013-empathy-3481670915dcd593d7156bda1aec970a42890e0b.tar
gsoc2013-empathy-3481670915dcd593d7156bda1aec970a42890e0b.tar.gz
gsoc2013-empathy-3481670915dcd593d7156bda1aec970a42890e0b.tar.bz2
gsoc2013-empathy-3481670915dcd593d7156bda1aec970a42890e0b.tar.lz
gsoc2013-empathy-3481670915dcd593d7156bda1aec970a42890e0b.tar.xz
gsoc2013-empathy-3481670915dcd593d7156bda1aec970a42890e0b.tar.zst
gsoc2013-empathy-3481670915dcd593d7156bda1aec970a42890e0b.zip
Adding spellcheck support.
2007-06-10 Xavier Claessens <xclaesse@gmail.com> * libempathy-gtk/gossip-spell-dialog.glade: * libempathy-gtk/gossip-spell-dialog.c: * libempathy-gtk/gossip-spell-dialog.h: * libempathy-gtk/gossip-chat.c: * libempathy-gtk/Makefile.am: * configure.ac: Adding spellcheck support. * libempathy-gtk/gossip-spell.c: * libempathy/gossip-conf.c: Remove useless debug messages. svn path=/trunk/; revision=144
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac54
1 files changed, 46 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 4371b6a7a..3be2cd838 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,14 +75,52 @@ PKG_CHECK_MODULES(EMPATHY,
libgnomeui-2.0
])
-PKG_CHECK_MODULES(MISSION_CONTROL_PLUGINS,
-[
- mission-control >= $MISSION_CONTROL_REQUIRED
- glib-2.0 >= $GLIB_REQUIRED
- gobject-2.0
- dbus-glib-1
- libtelepathy >= $TELEPATHY_REQUIRED
-])
+dnl -----------------------------------------------------------
+dnl ISO codes, used for aspell support
+dnl -----------------------------------------------------------
+AC_MSG_CHECKING([whether iso-codes exists and has iso-639 domain])
+if $PKG_CONFIG --variable=domains iso-codes | grep -q 639 ; then
+ AC_MSG_RESULT([yes])
+ iso_codes_prefix=`$PKG_CONFIG --variable=prefix iso-codes`
+ iso_codes_pkgconfig=iso-codes
+ have_iso_codes=yes
+else
+ AC_MSG_RESULT([no])
+ iso_codes_prefix=
+ iso_codes_pkgconfig=
+ have_iso_codes=no
+fi
+
+AC_DEFINE_UNQUOTED([ISO_CODES_PREFIX],["$iso_codes_prefix"],[ISO codes prefix])
+
+dnl -----------------------------------------------------------
+dnl ASpell
+dnl -----------------------------------------------------------
+AC_ARG_ENABLE(aspell,
+ AS_HELP_STRING([--enable-aspell=@<:@no/yes/auto@:>@],
+ [compile with aspell support]), ,
+ enable_aspell=auto)
+
+if test "x$enable_aspell" = "xyes" -a "x$have_iso_codes" != "xyes"; then
+ AC_MSG_ERROR([You must have iso-codes with the iso-639 domain to use aspell.])
+fi
+
+if test "x$enable_aspell" != "xno" -a "x$have_iso_codes" = "xyes"; then
+ AC_CHECK_LIB(aspell, aspell_speller_check,have_aspell=yes,have_aspell=no,)
+
+ if test "x$have_aspell" = "xyes"; then
+ AC_DEFINE(HAVE_ASPELL, 1, [Define if we have aspell])
+ EMPATHY_LIBS="$EMPATHY_LIBS -laspell"
+ else
+ have_aspell=no
+ fi
+else
+ have_aspell=no
+fi
+
+if test "x$enable_aspell" = "xyes" -a "x$have_aspell" != "xyes"; then
+ AC_MSG_ERROR([Couldn't find aspell.])
+fi
dnl -----------------------------------------------------------
AC_OUTPUT([