aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2007-12-29 23:49:28 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-12-29 23:49:28 +0800
commit2c4f7c6b6549f8b95845f1838dd0dc710c9e8304 (patch)
tree73f77284e63c07544111aae1cea50f8fced8acf0 /configure.ac
parent876e427bafc95f2f13a333b9bca0d8982b7faf3d (diff)
downloadgsoc2013-empathy-2c4f7c6b6549f8b95845f1838dd0dc710c9e8304.tar
gsoc2013-empathy-2c4f7c6b6549f8b95845f1838dd0dc710c9e8304.tar.gz
gsoc2013-empathy-2c4f7c6b6549f8b95845f1838dd0dc710c9e8304.tar.bz2
gsoc2013-empathy-2c4f7c6b6549f8b95845f1838dd0dc710c9e8304.tar.lz
gsoc2013-empathy-2c4f7c6b6549f8b95845f1838dd0dc710c9e8304.tar.xz
gsoc2013-empathy-2c4f7c6b6549f8b95845f1838dd0dc710c9e8304.tar.zst
gsoc2013-empathy-2c4f7c6b6549f8b95845f1838dd0dc710c9e8304.zip
Add "check" framework support. Fixes bug #505622 (Guillaume Desmottes).
svn path=/trunk/; revision=509
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 23 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c86b1190f..4f164ac78 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,7 @@ MISSION_CONTROL_REQUIRED=4.37
# AC_DEFINE(G_DISABLE_DEPRECATED, 1, [Disable deprecated GLib symbols])
# AC_DEFINE(LIBTELEPATHY_DISABLE_DEPRECATED, 1, [Disable deprecated libtelepathy symbols])
+AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_AUX_DIR(.)
AM_CONFIG_HEADER(config.h)
AM_INIT_AUTOMAKE(1.9 dist-bzip2 no-define)
@@ -210,11 +211,24 @@ AM_CONDITIONAL(HAVE_NOTHERE, test "x$have_nothere" = "xyes")
# Tests
# -----------------------------------------------------------
AC_ARG_ENABLE(tests,
- AS_HELP_STRING([--enable-tests=@<:@no/yes@:>@],
+ AS_HELP_STRING([--enable-tests=@<:@no/yes/auto@:>@],
[build tests]), ,
enable_tests=no)
-AM_CONDITIONAL(HAVE_TESTS, test "x$enable_tests" = "xyes")
+if test "x$enable_tests" != "xno"; then
+ PKG_CHECK_MODULES(CHECK,
+ [
+ check >= 0.9.4
+ ], have_check="yes", have_check="no")
+else
+ have_check=no
+fi
+
+if test "x$enable_tests" = "xyes" -a "x$have_check" != "xyes"; then
+ AC_MSG_ERROR([Couldn't find check dependencies.])
+fi
+
+AM_CONDITIONAL(HAVE_TESTS, test "x$have_check" = "xyes")
# -----------------------------------------------------------
# Python Bindings
@@ -267,6 +281,12 @@ fi
AM_CONDITIONAL(HAVE_VOIP, test "x$enable_voip" = "xyes")
+# Checks for the 'check' unit testing library
+PKG_CHECK_MODULES([CHECK], [check >= 0.9.4],
+ [ HAVE_CHECK=yes ],
+ [ HAVE_CHECK=no ] )
+AM_CONDITIONAL(HAVE_CHECK, test "x$HAVE_CHECK" = "xyes")
+
# -----------------------------------------------------------
AC_OUTPUT([
@@ -280,6 +300,7 @@ AC_OUTPUT([
libempathy-gtk/Makefile
libempathy-gtk/libempathy-gtk.pc
src/Makefile
+ m4/Makefile
megaphone/Makefile
megaphone/src/Makefile
megaphone/data/Makefile