aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@gmail.com>2007-09-21 19:11:35 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2007-09-21 19:11:35 +0800
commit004e5e331b89484f2448ab81d0e97cfc3b47af18 (patch)
tree4eea8d5349942d490b4ef9fac9c6c62d91177a20 /configure.ac
parent1382956b87b5114aa35f4357d7edcf9d5507a2c0 (diff)
downloadgsoc2013-empathy-004e5e331b89484f2448ab81d0e97cfc3b47af18.tar
gsoc2013-empathy-004e5e331b89484f2448ab81d0e97cfc3b47af18.tar.gz
gsoc2013-empathy-004e5e331b89484f2448ab81d0e97cfc3b47af18.tar.bz2
gsoc2013-empathy-004e5e331b89484f2448ab81d0e97cfc3b47af18.tar.lz
gsoc2013-empathy-004e5e331b89484f2448ab81d0e97cfc3b47af18.tar.xz
gsoc2013-empathy-004e5e331b89484f2448ab81d0e97cfc3b47af18.tar.zst
gsoc2013-empathy-004e5e331b89484f2448ab81d0e97cfc3b47af18.zip
Fix ref count error for account objects.
2007-09-21 Xavier Claessens <xclaesse@gmail.com> * libempathy-gtk/empathy-contact-list-view.c: Fix ref count error for account objects. * libempathy/empathy-contact-manager.c: Disconnect signals from MissionControl object when finalising the contact manager. * configure.ac: * megaphone/src/megaphone-applet.c: * megaphone/src/Makefile.am: * megaphone/src/megaphone-applet.h: * megaphone/data/GNOME_Megaphone_Applet.schemas.in: * megaphone/data/Makefile.am: * megaphone/data/GNOME_Megaphone_Applet.server.in.in: * megaphone/data/GNOME_Megaphone_Applet.xml: * megaphone/Makefile.am: * nothere/src/nothere-applet.c: * nothere/src/Makefile.am: * nothere/src/nothere-applet.h: * nothere/data/Makefile.am: * nothere/data/GNOME_NotHere_Applet.server.in.in: * nothere/data/GNOME_NotHere_Applet.xml: * nothere/Makefile.am: * Makefile.am: * po/POTFILES.in: * po/POTFILES.skip: Add Megaphone and Nothere applets. Fixes bug #464954 (Raphael Slinckx, Xavier Claessens). svn path=/trunk/; revision=303
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac69
1 files changed, 67 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6c88627b9..a3e865f28 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,9 +46,10 @@ IT_PROG_INTLTOOL([0.35.0])
GTK_DOC_CHECK([1.3])
GLIB_REQUIRED=2.12.0
-GTK_REQUIRED=2.10.0
+GTK_REQUIRED=2.12.0
GCONF_REQUIRED=1.2.0
LIBGLADE_REQUIRED=2.0.0
+LIBPANELAPPLET_REQUIRED=2.10.0
TELEPATHY_REQUIRED=0.0.57
MISSION_CONTROL_REQUIRED=4.33
@@ -145,6 +146,65 @@ fi
dnl -----------------------------------------------------------
+dnl Megaphone
+dnl -----------------------------------------------------------
+AC_ARG_ENABLE(megaphone,
+ AS_HELP_STRING([--enable-megaphone=@<:@no/yes/auto@:>@],
+ [build megaphone applet]), ,
+ enable_megaphone=auto)
+
+if test "x$enable_megaphone" != "xno"; then
+ PKG_CHECK_MODULES(MEGAPHONE,
+ [
+ libpanelapplet-2.0 >= $LIBPANELAPPLET_REQUIRED
+ glib-2.0 >= $GLIB_REQUIRED
+ gtk+-2.0 >= $GTK_REQUIRED
+ gconf-2.0 >= $GCONF_REQUIRED
+ libglade-2.0 >= $LIBGLADE_REQUIRED
+ gnome-vfs-2.0
+ libtelepathy >= $TELEPATHY_REQUIRED
+ libmissioncontrol >= $MISSION_CONTROL_REQUIRED
+ ], have_megaphone="yes", have_megaphone="no")
+else
+ have_megaphone=no
+fi
+
+if test "x$enable_megaphone" = "xyes" -a "x$have_megaphone" != "xyes"; then
+ AC_MSG_ERROR([Couldn't find megaphone dependencies.])
+fi
+
+AM_CONDITIONAL(HAVE_MEGAPHONE, test "x$have_megaphone" = "xyes")
+
+dnl -----------------------------------------------------------
+dnl Nothere
+dnl -----------------------------------------------------------
+AC_ARG_ENABLE(nothere,
+ AS_HELP_STRING([--enable-nothere=@<:@no/yes/auto@:>@],
+ [build nothere applet]), ,
+ enable_nothere=no)
+
+if test "x$enable_nothere" != "xno"; then
+ PKG_CHECK_MODULES(NOTHERE,
+ [
+ libpanelapplet-2.0 >= $LIBPANELAPPLET_REQUIRED
+ glib-2.0 >= $GLIB_REQUIRED
+ gtk+-2.0 >= $GTK_REQUIRED
+ gconf-2.0 >= $GCONF_REQUIRED
+ libglade-2.0 >= $LIBGLADE_REQUIRED
+ libtelepathy >= $TELEPATHY_REQUIRED
+ libmissioncontrol >= $MISSION_CONTROL_REQUIRED
+ ], have_nothere="yes", have_nothere="no")
+else
+ have_nothere=no
+fi
+
+if test "x$enable_nothere" = "xyes" -a "x$have_nothere" != "xyes"; then
+ AC_MSG_ERROR([Couldn't find nothere dependencies.])
+fi
+
+AM_CONDITIONAL(HAVE_NOTHERE, test "x$have_nothere" = "xyes")
+
+dnl -----------------------------------------------------------
dnl Python Bindings
dnl -----------------------------------------------------------
AC_ARG_ENABLE(python,
@@ -200,7 +260,12 @@ AC_OUTPUT([
libempathy-gtk/Makefile
libempathy-gtk/libempathy-gtk.pc
src/Makefile
- doc/Makefile
+ megaphone/Makefile
+ megaphone/src/Makefile
+ megaphone/data/Makefile
+ nothere/Makefile
+ nothere/src/Makefile
+ nothere/data/Makefile doc/Makefile
doc/libempathy/Makefile
doc/libempathy-gtk/Makefile
python/Makefile