aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorxclaesse <xclaesse@4ee84921-47dd-4033-b63a-18d7a039a3e4>2007-12-29 23:49:47 +0800
committerxclaesse <xclaesse@4ee84921-47dd-4033-b63a-18d7a039a3e4>2007-12-29 23:49:47 +0800
commit0cfd80847f0d66967f56c7d6b3eb46793f725859 (patch)
tree0004eceb52b4bb3a4da1275057e46ea80e840a05 /Makefile.am
parent748631b8a2ad06ad19b83e59102e0f963cad00ae (diff)
downloadgsoc2013-empathy-0cfd80847f0d66967f56c7d6b3eb46793f725859.tar
gsoc2013-empathy-0cfd80847f0d66967f56c7d6b3eb46793f725859.tar.gz
gsoc2013-empathy-0cfd80847f0d66967f56c7d6b3eb46793f725859.tar.bz2
gsoc2013-empathy-0cfd80847f0d66967f56c7d6b3eb46793f725859.tar.lz
gsoc2013-empathy-0cfd80847f0d66967f56c7d6b3eb46793f725859.tar.xz
gsoc2013-empathy-0cfd80847f0d66967f56c7d6b3eb46793f725859.tar.zst
gsoc2013-empathy-0cfd80847f0d66967f56c7d6b3eb46793f725859.zip
merge git work
git-svn-id: svn+ssh://svn.gnome.org/svn/empathy/trunk@518 4ee84921-47dd-4033-b63a-18d7a039a3e4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 2d207666b..4256f0f86 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,7 +33,6 @@ EXTRA_DIST = \
$(INTLTOOL)
DISTCLEANFILES = \
- ChangeLog \
intltool-extract \
intltool-merge \
intltool-update
@@ -42,9 +41,15 @@ DISTCLEANFILES = \
# uninstall.
distuninstallcheck_listfiles = find . -type f -print | grep -v '^\./var/scrollkeeper'
-ChangeLog: Makefile.am
- git-log --pretty=short > ChangeLog
-
+# Build ChangeLog from SVN history (r470 was the first ChangeLog-less checkin).
+# Only build this when in an svn checkout.
+
+ChangeLog:
+ @if test -f $(top_srcdir)/.svn/entries; then \
+ svn log -v --xml -r HEAD:470 $(SVN_ROOT)/$(SVN_MODULE) | \
+ xsltproc --stringparam strip-prefix "$(SVN_MODULE)/$(SVN_BRANCH)" \
+ --stringparam include-rev "yes" $(top_srcdir)/svn2cl.xsl - > $@; \
+ fi
dist: ChangeLog