aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSjoerd Simons <sjoerd.simons@collabora.co.uk>2010-06-20 03:29:51 +0800
committerSjoerd Simons <sjoerd.simons@collabora.co.uk>2010-06-20 03:29:51 +0800
commit96a20bbc3f491b9f6bfa00401beb4cf24b7a200c (patch)
tree2fd2e9018aae3ba6285cdc5b8a32f3b1fdd19e12
parentfb06bf8e12d112645433eb7ed2bd9ffb82980278 (diff)
downloadgsoc2013-empathy-96a20bbc3f491b9f6bfa00401beb4cf24b7a200c.tar
gsoc2013-empathy-96a20bbc3f491b9f6bfa00401beb4cf24b7a200c.tar.gz
gsoc2013-empathy-96a20bbc3f491b9f6bfa00401beb4cf24b7a200c.tar.bz2
gsoc2013-empathy-96a20bbc3f491b9f6bfa00401beb4cf24b7a200c.tar.lz
gsoc2013-empathy-96a20bbc3f491b9f6bfa00401beb4cf24b7a200c.tar.xz
gsoc2013-empathy-96a20bbc3f491b9f6bfa00401beb4cf24b7a200c.tar.zst
gsoc2013-empathy-96a20bbc3f491b9f6bfa00401beb4cf24b7a200c.zip
Now that we depend on the logger always enable favourite contact support
-rw-r--r--configure.ac30
-rw-r--r--libempathy-gtk/empathy-contact-list-store.c2
-rw-r--r--libempathy-gtk/empathy-contact-menu.c4
-rw-r--r--libempathy-gtk/empathy-contact-widget.c8
-rw-r--r--libempathy/empathy-contact-list.c6
5 files changed, 0 insertions, 50 deletions
diff --git a/configure.ac b/configure.ac
index f93fb695a..7c7721231 100644
--- a/configure.ac
+++ b/configure.ac
@@ -422,7 +422,6 @@ if test "x$enable_meego" != "xno"; then
if test "x$have_meego" = "xyes"; then
AC_DEFINE(HAVE_MEEGO, 1, [Define if you have meego])
- chain_enable_favourite_contacts="yes"
fi
else
have_meego="no"
@@ -437,34 +436,6 @@ AC_SUBST(MEEGO_CFLAGS)
AC_SUBST(MEEGO_LIBS)
# -----------------------------------------------------------
-# favourite contacts support
-# -----------------------------------------------------------
-AC_ARG_ENABLE(favourite_contacts,
- AS_HELP_STRING([--enable-favourite-contacts=@<:no/yes@:>@],
- [Enable favourite contacts]), ,
- enable_favourite_contacts=no)
-
-if test "x$enable_favourite_contacts" != "xno" || test "x$chain_enable_favourite_contacts" = "xyes"; then
- PKG_CHECK_MODULES(TELEPATHY_LOGGER,
- [
- telepathy-logger
- ], have_telepathy_logger="yes", have_telepathy_logger="no")
-
- if test "x$have_telepathy_logger" = "xyes"; then
- have_favourite_contacts="yes"
- AC_DEFINE(HAVE_FAVOURITE_CONTACTS, 1, [Define if you want favourite contacts support])
- fi
-else
- have_favourite_contacts="no"
-fi
-
-if test "x$enable_favourite_contacts" = "xyes" && test "x$have_favourite_contacts" != "xyes"; then
- AC_MSG_ERROR([Couldn't find favourite contacts dependencies.])
-fi
-
-AM_CONDITIONAL(HAVE_FAVOURITE_CONTACTS, test "x$have_telepathy_logger" = "xyes")
-
-# -----------------------------------------------------------
# nautilus-sendto
# -----------------------------------------------------------
AC_ARG_ENABLE(nautilus-sendto,
@@ -560,7 +531,6 @@ Configure summary:
Location awareness (Geoclue): ${have_geoclue}
Adium themes (Webkit).......: ${have_webkit}
Meego widgets ..............: ${have_meego}
- Favourite contacts .........: ${have_favourite_contacts}
Control center embedding....: ${have_control_center_embedding}
Connectivity:
diff --git a/libempathy-gtk/empathy-contact-list-store.c b/libempathy-gtk/empathy-contact-list-store.c
index 98cd81b5d..d5969c87b 100644
--- a/libempathy-gtk/empathy-contact-list-store.c
+++ b/libempathy-gtk/empathy-contact-list-store.c
@@ -1061,7 +1061,6 @@ contact_list_store_add_contact (EmpathyContactListStore *store,
}
g_list_free (groups);
-#ifdef HAVE_FAVOURITE_CONTACTS
if (priv->show_groups &&
empathy_contact_list_is_favourite (priv->list, contact)) {
/* Add contact to the fake 'Favorites' group */
@@ -1072,7 +1071,6 @@ contact_list_store_add_contact (EmpathyContactListStore *store,
add_contact_to_store (GTK_TREE_STORE (store), &iter, &iter_group, contact, flags);
}
-#endif
contact_list_store_contact_update (store, contact);
}
diff --git a/libempathy-gtk/empathy-contact-menu.c b/libempathy-gtk/empathy-contact-menu.c
index 9ea19af32..9b49389c1 100644
--- a/libempathy-gtk/empathy-contact-menu.c
+++ b/libempathy-gtk/empathy-contact-menu.c
@@ -131,14 +131,12 @@ empathy_contact_menu_new (EmpathyContact *contact,
gtk_widget_show (item);
}
-#if HAVE_FAVOURITE_CONTACTS
/* Favorite checkbox */
if (features & EMPATHY_CONTACT_FEATURE_FAVOURITE) {
item = empathy_contact_favourite_menu_item_new (contact);
gtk_menu_shell_append (shell, item);
gtk_widget_show (item);
}
-#endif
return menu;
}
@@ -392,7 +390,6 @@ empathy_contact_share_my_desktop_menu_item_new (EmpathyContact *contact)
return item;
}
-#if HAVE_FAVOURITE_CONTACTS
static void
favourite_menu_item_toggled_cb (GtkCheckMenuItem *item,
EmpathyContact *contact)
@@ -432,7 +429,6 @@ empathy_contact_favourite_menu_item_new (EmpathyContact *contact)
g_object_unref (manager);
return item;
}
-#endif
static void
contact_info_menu_item_activate_cb (EmpathyContact *contact)
diff --git a/libempathy-gtk/empathy-contact-widget.c b/libempathy-gtk/empathy-contact-widget.c
index 72fe321d7..e7a6b3a14 100644
--- a/libempathy-gtk/empathy-contact-widget.c
+++ b/libempathy-gtk/empathy-contact-widget.c
@@ -1405,7 +1405,6 @@ contact_widget_presence_notify_cb (EmpathyContactWidget *information)
gtk_widget_show (information->image_state);
}
-#if HAVE_FAVOURITE_CONTACTS
static void
contact_widget_favourites_changed_cb (EmpathyContactManager *manager,
EmpathyContact *contact,
@@ -1418,7 +1417,6 @@ contact_widget_favourites_changed_cb (EmpathyContactManager *manager,
gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (
information->favourite_checkbox), is_favourite);
}
-#endif
static void
contact_widget_remove_contact (EmpathyContactWidget *information)
@@ -1524,7 +1522,6 @@ contact_widget_contact_update (EmpathyContactWidget *information)
contact_widget_presence_notify_cb (information);
contact_widget_avatar_notify_cb (information);
-#if HAVE_FAVOURITE_CONTACTS
if (information->flags & EMPATHY_CONTACT_WIDGET_EDIT_FAVOURITE)
{
gboolean is_favourite;
@@ -1536,7 +1533,6 @@ contact_widget_contact_update (EmpathyContactWidget *information)
contact_widget_favourites_changed_cb (information->manager,
information->contact, is_favourite, information);
}
-#endif
gtk_widget_show (information->label_alias);
gtk_widget_show (information->widget_alias);
@@ -1657,7 +1653,6 @@ contact_widget_id_focus_out_cb (GtkWidget *widget,
return FALSE;
}
-#if HAVE_FAVOURITE_CONTACTS
static void
favourite_toggled_cb (GtkToggleButton *button,
EmpathyContactWidget *information)
@@ -1677,7 +1672,6 @@ favourite_toggled_cb (GtkToggleButton *button,
EMPATHY_CONTACT_LIST (information->manager), information->contact);
}
}
-#endif
static void
contact_widget_contact_setup (EmpathyContactWidget *information)
@@ -1817,7 +1811,6 @@ contact_widget_contact_setup (EmpathyContactWidget *information)
}
gtk_widget_show (information->widget_alias);
-#if HAVE_FAVOURITE_CONTACTS
/* Favorite */
if (information->flags & EMPATHY_CONTACT_WIDGET_EDIT_FAVOURITE)
{
@@ -1836,7 +1829,6 @@ contact_widget_contact_setup (EmpathyContactWidget *information)
gtk_widget_show (information->favourite_checkbox);
}
-#endif
}
static void
diff --git a/libempathy/empathy-contact-list.c b/libempathy/empathy-contact-list.c
index 5cbe1cb15..631bb4a37 100644
--- a/libempathy/empathy-contact-list.c
+++ b/libempathy/empathy-contact-list.c
@@ -251,12 +251,10 @@ gboolean
empathy_contact_list_is_favourite (EmpathyContactList *list,
EmpathyContact *contact)
{
-#if HAVE_FAVOURITE_CONTACTS
if (EMPATHY_CONTACT_LIST_GET_IFACE (list)->is_favourite) {
return EMPATHY_CONTACT_LIST_GET_IFACE (list)->is_favourite (
list, contact);
}
-#endif /* HAVE_FAVOURITE_CONTACTS */
return FALSE;
}
@@ -265,22 +263,18 @@ void
empathy_contact_list_add_to_favourites (EmpathyContactList *list,
EmpathyContact *contact)
{
-#if HAVE_FAVOURITE_CONTACTS
if (EMPATHY_CONTACT_LIST_GET_IFACE (list)->add_favourite) {
EMPATHY_CONTACT_LIST_GET_IFACE (list)->add_favourite (list,
contact);
}
-#endif /* HAVE_FAVOURITE_CONTACTS */
}
void
empathy_contact_list_remove_from_favourites (EmpathyContactList *list,
EmpathyContact *contact)
{
-#if HAVE_FAVOURITE_CONTACTS
if (EMPATHY_CONTACT_LIST_GET_IFACE (list)->remove_favourite) {
EMPATHY_CONTACT_LIST_GET_IFACE (list)->remove_favourite (list,
contact);
}
-#endif /* HAVE_FAVOURITE_CONTACTS */
}