aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2011-05-31 22:29:39 +0800
committerEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2011-05-31 22:29:39 +0800
commit009dd844a395304ec3578043fececed62dc08081 (patch)
tree8cb505327f66a75e35bcdbfcc00601b85ab63e5a
parentd45a047f7b70d035658aba2e41f703a6e2ea3538 (diff)
downloadgsoc2013-empathy-009dd844a395304ec3578043fececed62dc08081.tar
gsoc2013-empathy-009dd844a395304ec3578043fececed62dc08081.tar.gz
gsoc2013-empathy-009dd844a395304ec3578043fececed62dc08081.tar.bz2
gsoc2013-empathy-009dd844a395304ec3578043fececed62dc08081.tar.lz
gsoc2013-empathy-009dd844a395304ec3578043fececed62dc08081.tar.xz
gsoc2013-empathy-009dd844a395304ec3578043fececed62dc08081.tar.zst
gsoc2013-empathy-009dd844a395304ec3578043fececed62dc08081.zip
Patches refreshed
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/20_libindicate.patch36
-rw-r--r--debian/patches/23_idomessagedialog_for_voip_and_ft.patch2
-rw-r--r--debian/patches/34_start_raised_execpt_in_session.patch4
-rw-r--r--debian/patches/40_unity_launcher_count.patch12
5 files changed, 28 insertions, 27 deletions
diff --git a/debian/changelog b/debian/changelog
index 96384978a..3114a905f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
empathy (2.34.0+git.20110531.338a6e-0ubuntu0+easton1) natty; urgency=low
* New upstream snapshot.
+ * Patches refreshed.
-- Emilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk> Tue, 31 May 2011 15:20:12 +0100
diff --git a/debian/patches/20_libindicate.patch b/debian/patches/20_libindicate.patch
index 5d5812edf..dade716a7 100644
--- a/debian/patches/20_libindicate.patch
+++ b/debian/patches/20_libindicate.patch
@@ -3,14 +3,14 @@
+++ b/configure.ac
@@ -56,6 +56,8 @@
NETWORK_MANAGER_REQUIRED=0.7.0
- WEBKIT_REQUIRED=1.1.15
+ WEBKIT_REQUIRED=1.3.13
GNOME_CONTROL_CENTER_GTK3_REQUIRED=2.31.4
+INDICATE_REQUIRED=0.4.91
+INDICATE_GTK_REQUIRED=0.4.91
# telepathy-yell
prev_top_build_prefix=$ac_top_build_prefix
-@@ -498,6 +500,34 @@
+@@ -523,6 +525,34 @@
AC_SUBST(MEEGO_LIBS)
# -----------------------------------------------------------
@@ -45,7 +45,7 @@
# nautilus-sendto
# -----------------------------------------------------------
AC_ARG_ENABLE(nautilus-sendto,
-@@ -599,6 +629,7 @@
+@@ -624,6 +654,7 @@
CA Cert Path................: ${GTLS_SYSTEM_CA_FILE}
Features:
@@ -222,7 +222,7 @@
GtkTargetList *contact_targets;
GtkTargetList *file_targets;
-@@ -1330,6 +1339,72 @@
+@@ -1333,6 +1342,72 @@
}
}
@@ -295,7 +295,7 @@
static void
chat_window_show_or_update_notification (EmpathyChatWindow *window,
EmpathyMessage *message,
-@@ -1508,6 +1583,9 @@
+@@ -1512,6 +1587,9 @@
empathy_sound_play (GTK_WIDGET (priv->dialog),
EMPATHY_SOUND_MESSAGE_INCOMING);
@@ -305,7 +305,7 @@
/* Pending messages have already been displayed in the approver, so we don't
* display a notification for those. */
-@@ -1580,6 +1658,10 @@
+@@ -1584,6 +1662,10 @@
empathy_chat_messages_read (chat);
chat_window_update_chat_tab (chat);
@@ -316,7 +316,7 @@
}
static void
-@@ -1696,6 +1778,11 @@
+@@ -1700,6 +1782,11 @@
/* Update the title, since we now mark all unread messages as read. */
chat_window_update_chat_tab_full (priv->current_chat, FALSE);
@@ -328,7 +328,7 @@
return FALSE;
}
-@@ -2040,6 +2127,11 @@
+@@ -2046,6 +2133,11 @@
g_object_unref (gui);
priv->chatroom_manager = empathy_chatroom_manager_dup_singleton (NULL);
@@ -1310,7 +1310,7 @@
/* The idle event source to migrate butterfly's logs */
guint butterfly_log_migration_members_changed_id;
-@@ -437,11 +445,23 @@
+@@ -440,11 +448,23 @@
EmpathyEvent *event,
EmpathyMainWindow *window)
{
@@ -1334,7 +1334,7 @@
}
static void
-@@ -1321,6 +1341,10 @@
+@@ -1348,6 +1368,10 @@
g_object_unref (priv->ui_manager);
g_object_unref (priv->chatroom_manager);
@@ -1345,7 +1345,7 @@
g_object_unref (priv->gsettings_ui);
g_object_unref (priv->gsettings_contacts);
-@@ -2401,6 +2425,10 @@
+@@ -2431,6 +2455,10 @@
l = l->next;
}
@@ -1448,7 +1448,7 @@
} EmpathyStatusIconPriv;
G_DEFINE_TYPE (EmpathyStatusIcon, empathy_status_icon, G_TYPE_OBJECT);
-@@ -457,6 +468,92 @@
+@@ -458,6 +469,92 @@
empathy_window_present (GTK_WINDOW (priv->window));
}
}
@@ -1541,7 +1541,7 @@
static void
status_icon_notify_visibility_cb (GSettings *gsettings,
-@@ -476,10 +573,36 @@
+@@ -477,10 +574,36 @@
EmpathyStatusIconPriv *priv = GET_PRIV (icon);
gboolean visible;
@@ -1578,7 +1578,7 @@
static void
status_icon_presence_changed_cb (EmpathyStatusIcon *icon)
{
-@@ -663,6 +786,9 @@
+@@ -664,6 +787,9 @@
g_object_unref (priv->notify_mgr);
g_object_unref (priv->gsettings_ui);
g_object_unref (priv->window);
@@ -1588,7 +1588,7 @@
}
static void
-@@ -723,6 +849,13 @@
+@@ -724,6 +850,13 @@
G_CALLBACK (status_icon_notify_visibility_cb),
icon);
@@ -1602,7 +1602,7 @@
status_icon_create_menu (icon);
g_signal_connect_swapped (priv->account_manager,
-@@ -755,6 +888,9 @@
+@@ -756,6 +889,9 @@
EmpathyStatusIconPriv *priv;
EmpathyStatusIcon *icon;
gboolean should_hide;
@@ -1612,7 +1612,7 @@
g_return_val_if_fail (GTK_IS_WINDOW (window), NULL);
-@@ -762,6 +898,24 @@
+@@ -763,6 +899,24 @@
priv = GET_PRIV (icon);
priv->window = g_object_ref (window);
@@ -1637,7 +1637,7 @@
g_signal_connect_after (priv->window, "key-press-event",
G_CALLBACK (status_icon_key_press_event_cb),
-@@ -778,6 +932,12 @@
+@@ -779,6 +933,12 @@
should_hide = TRUE;
}
diff --git a/debian/patches/23_idomessagedialog_for_voip_and_ft.patch b/debian/patches/23_idomessagedialog_for_voip_and_ft.patch
index fa944f9f3..f47e76a5c 100644
--- a/debian/patches/23_idomessagedialog_for_voip_and_ft.patch
+++ b/debian/patches/23_idomessagedialog_for_voip_and_ft.patch
@@ -3,7 +3,7 @@
+++ b/configure.ac
@@ -44,6 +44,7 @@
TELEPATHY_GLIB_REQUIRED=0.14.1
- TELEPATHY_LOGGER=0.2.8
+ TELEPATHY_LOGGER=0.2.10
UNIQUE_REQUIRED=1.1.2
+IDO_REQUIRED=0.1.14
diff --git a/debian/patches/34_start_raised_execpt_in_session.patch b/debian/patches/34_start_raised_execpt_in_session.patch
index b92af8356..051c48728 100644
--- a/debian/patches/34_start_raised_execpt_in_session.patch
+++ b/debian/patches/34_start_raised_execpt_in_session.patch
@@ -4,7 +4,7 @@ Bug: bugs.launchpad.net/bugs/503052
=== modified file 'src/empathy-status-icon.c'
--- a/src/empathy-status-icon.c
+++ b/src/empathy-status-icon.c
-@@ -897,6 +897,9 @@
+@@ -898,6 +898,9 @@
#ifdef HAVE_LIBINDICATE
gboolean use_libindicate;
#endif
@@ -14,7 +14,7 @@ Bug: bugs.launchpad.net/bugs/503052
g_return_val_if_fail (GTK_IS_WINDOW (window), NULL);
-@@ -932,8 +935,16 @@
+@@ -933,8 +936,16 @@
icon);
if (!hide_contact_list) {
diff --git a/debian/patches/40_unity_launcher_count.patch b/debian/patches/40_unity_launcher_count.patch
index fa0fe2866..4752a4b76 100644
--- a/debian/patches/40_unity_launcher_count.patch
+++ b/debian/patches/40_unity_launcher_count.patch
@@ -9,7 +9,7 @@
# telepathy-yell
prev_top_build_prefix=$ac_top_build_prefix
-@@ -524,12 +525,41 @@
+@@ -549,12 +550,41 @@
fi
if test "x$enable_libindicate" = "xyes" -a "x$have_libindicate" != "xyes"; then
@@ -52,7 +52,7 @@
# nautilus-sendto
# -----------------------------------------------------------
AC_ARG_ENABLE(nautilus-sendto,
-@@ -632,6 +662,7 @@
+@@ -657,6 +687,7 @@
Features:
Message indicator support (libindicate): ${have_libindicate}
@@ -109,7 +109,7 @@
GtkTargetList *contact_targets;
GtkTargetList *file_targets;
-@@ -1381,8 +1388,19 @@
+@@ -1384,8 +1391,19 @@
sender, body);
g_signal_connect (indicator, "activate",
G_CALLBACK (chat_window_indicator_activate_cb), chat);
@@ -130,7 +130,7 @@
}
empathy_indicator_show (indicator);
}
-@@ -1399,6 +1417,25 @@
+@@ -1402,6 +1420,25 @@
DEBUG ("indicator is %p", indicator);
empathy_indicator_hide (indicator);
g_hash_table_remove (priv->indicators, chat);
@@ -156,7 +156,7 @@
} else {
DEBUG ("indicator is NULL, nothing to remove");
}
-@@ -2034,6 +2071,11 @@
+@@ -2040,6 +2077,11 @@
priv->chat_manager = NULL;
}
@@ -168,7 +168,7 @@
chat_windows = g_list_remove (chat_windows, window);
gtk_widget_destroy (priv->dialog);
-@@ -2132,6 +2174,9 @@
+@@ -2138,6 +2180,9 @@
priv->indicators = g_hash_table_new_full (g_direct_hash, g_direct_equal,
NULL, g_object_unref);
#endif