aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2011-03-24 02:38:33 +0800
committerEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2011-04-09 00:03:39 +0800
commit87e92a9dd9f2047898612f3aab5c9c824c6b0b52 (patch)
tree2923bf58affe09457394f2eab1096a0a71af2122
parentf51b7cd067921da3d8f80986eff3cc2d67e8674c (diff)
downloadgsoc2013-empathy-87e92a9dd9f2047898612f3aab5c9c824c6b0b52.tar
gsoc2013-empathy-87e92a9dd9f2047898612f3aab5c9c824c6b0b52.tar.gz
gsoc2013-empathy-87e92a9dd9f2047898612f3aab5c9c824c6b0b52.tar.bz2
gsoc2013-empathy-87e92a9dd9f2047898612f3aab5c9c824c6b0b52.tar.lz
gsoc2013-empathy-87e92a9dd9f2047898612f3aab5c9c824c6b0b52.tar.xz
gsoc2013-empathy-87e92a9dd9f2047898612f3aab5c9c824c6b0b52.tar.zst
gsoc2013-empathy-87e92a9dd9f2047898612f3aab5c9c824c6b0b52.zip
New upstream snapshot
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/20_libindicate.patch24
-rw-r--r--debian/patches/23_idomessagedialog_for_voip_and_ft.patch12
-rw-r--r--debian/patches/31_really_raise_window.patch6
-rw-r--r--debian/patches/34_start_raised_execpt_in_session.patch4
5 files changed, 31 insertions, 23 deletions
diff --git a/debian/changelog b/debian/changelog
index 1295f808c..f4bcea8d4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+empathy (2.33.4+git.20110323.2fa120-0ubuntu0+easton1) natty; urgency=low
+
+ * New upstream snapshot.
+ + debian/patches/*:
+ - Refreshed.
+
+ -- Emilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk> Wed, 23 Mar 2011 18:37:02 +0000
+
empathy (2.33.4+git.20110322.4c31c2-0ubuntu0+easton1) natty; urgency=low
* New upstream snapshot.
diff --git a/debian/patches/20_libindicate.patch b/debian/patches/20_libindicate.patch
index e9de8498e..ff78d8bf8 100644
--- a/debian/patches/20_libindicate.patch
+++ b/debian/patches/20_libindicate.patch
@@ -10,7 +10,7 @@
# telepathy-yell
prev_top_build_prefix=$ac_top_build_prefix
-@@ -481,6 +483,34 @@
+@@ -480,6 +482,34 @@
AC_SUBST(MEEGO_LIBS)
# -----------------------------------------------------------
@@ -45,7 +45,7 @@
# nautilus-sendto
# -----------------------------------------------------------
AC_ARG_ENABLE(nautilus-sendto,
-@@ -582,6 +612,7 @@
+@@ -581,6 +611,7 @@
CA Cert Path................: ${GTLS_SYSTEM_CA_FILE}
Features:
@@ -69,7 +69,7 @@
<key name="sort-criterium" type="s">
--- a/libempathy-gtk/empathy-ui-utils.c
+++ b/libempathy-gtk/empathy-ui-utils.c
-@@ -1564,25 +1564,36 @@
+@@ -1567,25 +1567,36 @@
Display *dpy;
GdkWindow *gdk_window;
@@ -1424,7 +1424,7 @@
#include <libnotify/notification.h>
#include <libnotify/notify.h>
-@@ -50,6 +51,12 @@
+@@ -52,6 +53,12 @@
#include "empathy-preferences.h"
#include "empathy-event-manager.h"
@@ -1437,7 +1437,7 @@
#define DEBUG_FLAG EMPATHY_DEBUG_DISPATCHER
#include <libempathy/empathy-debug.h>
-@@ -74,6 +81,10 @@
+@@ -76,6 +83,10 @@
GtkAction *show_window_item;
GtkAction *new_message_item;
GtkAction *status_item;
@@ -1448,7 +1448,7 @@
} EmpathyStatusIconPriv;
G_DEFINE_TYPE (EmpathyStatusIcon, empathy_status_icon, G_TYPE_OBJECT);
-@@ -424,6 +435,92 @@
+@@ -457,6 +468,92 @@
empathy_window_present (GTK_WINDOW (priv->window));
}
}
@@ -1541,7 +1541,7 @@
static void
status_icon_notify_visibility_cb (GSettings *gsettings,
-@@ -443,10 +540,36 @@
+@@ -476,10 +573,36 @@
EmpathyStatusIconPriv *priv = GET_PRIV (icon);
gboolean visible;
@@ -1578,7 +1578,7 @@
static void
status_icon_presence_changed_cb (EmpathyStatusIcon *icon)
{
-@@ -630,6 +753,9 @@
+@@ -663,6 +786,9 @@
g_object_unref (priv->notify_mgr);
g_object_unref (priv->gsettings_ui);
g_object_unref (priv->window);
@@ -1588,7 +1588,7 @@
}
static void
-@@ -690,6 +816,13 @@
+@@ -723,6 +849,13 @@
G_CALLBACK (status_icon_notify_visibility_cb),
icon);
@@ -1602,7 +1602,7 @@
status_icon_create_menu (icon);
g_signal_connect_swapped (priv->account_manager,
-@@ -722,6 +855,9 @@
+@@ -755,6 +888,9 @@
EmpathyStatusIconPriv *priv;
EmpathyStatusIcon *icon;
gboolean should_hide;
@@ -1612,7 +1612,7 @@
g_return_val_if_fail (GTK_IS_WINDOW (window), NULL);
-@@ -729,6 +865,24 @@
+@@ -762,6 +898,24 @@
priv = GET_PRIV (icon);
priv->window = g_object_ref (window);
@@ -1637,7 +1637,7 @@
g_signal_connect_after (priv->window, "key-press-event",
G_CALLBACK (status_icon_key_press_event_cb),
-@@ -745,6 +899,12 @@
+@@ -778,6 +932,12 @@
should_hide = TRUE;
}
diff --git a/debian/patches/23_idomessagedialog_for_voip_and_ft.patch b/debian/patches/23_idomessagedialog_for_voip_and_ft.patch
index 823c0818c..f6b701fbf 100644
--- a/debian/patches/23_idomessagedialog_for_voip_and_ft.patch
+++ b/debian/patches/23_idomessagedialog_for_voip_and_ft.patch
@@ -29,7 +29,7 @@
#include "empathy-event-manager.h"
#include "empathy-main-window.h"
-@@ -470,6 +473,7 @@
+@@ -473,6 +476,7 @@
}
}
@@ -37,7 +37,7 @@
static void
event_manager_call_window_confirmation_dialog_response_cb (GtkDialog *dialog,
gint response, gpointer user_data)
-@@ -490,13 +494,75 @@
+@@ -499,13 +503,75 @@
}
static void
@@ -111,10 +111,10 @@
- gchar *title;
+ gint width, height;
+ GdkPixbuf *avatar;
+ EmpathyEventType etype = event->public.type;
if (event->approval->dialog != NULL)
- {
-@@ -522,33 +588,33 @@
+@@ -532,33 +598,33 @@
return;
}
@@ -167,7 +167,7 @@
gtk_message_dialog_set_image (GTK_MESSAGE_DIALOG (dialog), image);
gtk_widget_show (image);
-@@ -934,7 +1000,7 @@
+@@ -955,7 +1021,7 @@
event_manager_add (approval->manager, NULL,
approval->contact, EMPATHY_EVENT_TYPE_TRANSFER,
EMPATHY_IMAGE_DOCUMENT_SEND, header, NULL,
@@ -193,7 +193,7 @@
IndicatorEvent *indicator_event;
--- a/src/empathy-status-icon.c
+++ b/src/empathy-status-icon.c
-@@ -193,6 +193,12 @@
+@@ -226,6 +226,12 @@
}
if (priv->event) {
diff --git a/debian/patches/31_really_raise_window.patch b/debian/patches/31_really_raise_window.patch
index 253570aad..b4a7a5206 100644
--- a/debian/patches/31_really_raise_window.patch
+++ b/debian/patches/31_really_raise_window.patch
@@ -4,7 +4,7 @@ Bug: https://bugs.launchpad.net/bugs/442389
=== modified file 'libempathy-gtk/empathy-ui-utils.c'
--- a/libempathy-gtk/empathy-ui-utils.c
+++ b/libempathy-gtk/empathy-ui-utils.c
-@@ -1596,6 +1596,41 @@
+@@ -1599,6 +1599,41 @@
}
}
@@ -46,7 +46,7 @@ Bug: https://bugs.launchpad.net/bugs/442389
/* Takes care of moving the window to the current workspace. */
void
empathy_window_present_with_time (GtkWindow *window,
-@@ -1630,6 +1665,7 @@
+@@ -1633,6 +1668,7 @@
gtk_window_set_skip_taskbar_hint (window, FALSE);
gtk_window_deiconify (window);
@@ -64,7 +64,7 @@ Bug: https://bugs.launchpad.net/bugs/442389
#include <libido/idomessagedialog.h>
#include <libempathy-gtk/empathy-ui-utils.h>
-@@ -504,7 +505,7 @@
+@@ -513,7 +514,7 @@
if (event->approval->dialog != NULL)
{
diff --git a/debian/patches/34_start_raised_execpt_in_session.patch b/debian/patches/34_start_raised_execpt_in_session.patch
index e83aa7408..b92af8356 100644
--- a/debian/patches/34_start_raised_execpt_in_session.patch
+++ b/debian/patches/34_start_raised_execpt_in_session.patch
@@ -4,7 +4,7 @@ Bug: bugs.launchpad.net/bugs/503052
=== modified file 'src/empathy-status-icon.c'
--- a/src/empathy-status-icon.c
+++ b/src/empathy-status-icon.c
-@@ -864,6 +864,9 @@
+@@ -897,6 +897,9 @@
#ifdef HAVE_LIBINDICATE
gboolean use_libindicate;
#endif
@@ -14,7 +14,7 @@ Bug: bugs.launchpad.net/bugs/503052
g_return_val_if_fail (GTK_IS_WINDOW (window), NULL);
-@@ -899,8 +902,16 @@
+@@ -932,8 +935,16 @@
icon);
if (!hide_contact_list) {