aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2011-03-22 21:55:16 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2011-03-22 21:55:16 +0800
commit19d3ea612850bc3e2fabc387997e97ea11c89645 (patch)
tree6a332e8e04456fcb5a05f231344ca95b6744376a
parentc54f6252a002ad3c7b02f7339c4e81d4c2249e94 (diff)
parent965d24177d640c781ad76c91dddddf253aeff727 (diff)
downloadgsoc2013-empathy-19d3ea612850bc3e2fabc387997e97ea11c89645.tar
gsoc2013-empathy-19d3ea612850bc3e2fabc387997e97ea11c89645.tar.gz
gsoc2013-empathy-19d3ea612850bc3e2fabc387997e97ea11c89645.tar.bz2
gsoc2013-empathy-19d3ea612850bc3e2fabc387997e97ea11c89645.tar.lz
gsoc2013-empathy-19d3ea612850bc3e2fabc387997e97ea11c89645.tar.xz
gsoc2013-empathy-19d3ea612850bc3e2fabc387997e97ea11c89645.tar.zst
gsoc2013-empathy-19d3ea612850bc3e2fabc387997e97ea11c89645.zip
Merge branch 'stable-block-645504-2.34' into gnome-2-34
-rw-r--r--configure.ac2
-rw-r--r--extensions/Connection_Interface_Contact_Blocking.xml172
-rw-r--r--extensions/Makefile.am1
-rw-r--r--extensions/misc.xml1
-rw-r--r--libempathy/empathy-tp-contact-list.c12
5 files changed, 7 insertions, 181 deletions
diff --git a/configure.ac b/configure.ac
index e5e82801c..0a1b6ef56 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,7 +41,7 @@ KEYRING_REQUIRED=2.26.0
LIBCANBERRA_GTK_REQUIRED=0.4
LIBNOTIFY_REQUIRED=0.7.0
TELEPATHY_FARSIGHT_REQUIRED=0.0.14
-TELEPATHY_GLIB_REQUIRED=0.13.17
+TELEPATHY_GLIB_REQUIRED=0.14.1
TELEPATHY_LOGGER=0.2.0
UNIQUE_REQUIRED=1.1.2
diff --git a/extensions/Connection_Interface_Contact_Blocking.xml b/extensions/Connection_Interface_Contact_Blocking.xml
deleted file mode 100644
index 543d43a5c..000000000
--- a/extensions/Connection_Interface_Contact_Blocking.xml
+++ /dev/null
@@ -1,172 +0,0 @@
-<?xml version="1.0" ?>
-<node name="/Connection_Interface_Contact_Blocking" xmlns:tp="http://telepathy.freedesktop.org/wiki/DbusSpec#extensions-v0">
- <tp:copyright>Copyright © 2009-2010 Collabora Ltd.</tp:copyright>
- <tp:copyright>Copyright © 2009 Nokia Corporation</tp:copyright>
- <tp:license xmlns="http://www.w3.org/1999/xhtml">
- <p>This library is free software; you can redistribute it and/or
- modify it under the terms of the GNU Lesser General Public
- License as published by the Free Software Foundation; either
- version 2.1 of the License, or (at your option) any later version.</p>
-
- <p>This library is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
- Lesser General Public License for more details.</p>
-
- <p>You should have received a copy of the GNU Lesser General Public
- License along with this library; if not, write to the Free Software
- Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301,
- USA.</p>
- </tp:license>
- <interface name="org.freedesktop.Telepathy.Connection.Interface.ContactBlocking.DRAFT"
- tp:causes-havoc="experimental">
- <tp:requires interface="org.freedesktop.Telepathy.Connection"/>
-
- <tp:docstring xmlns="http://www.w3.org/1999/xhtml">
- <p>An interface for connections where contacts can be blocked from
- communicating with this user and receiving this user's presence.</p>
-
- <p>When this interface becomes stable, it will replace the <tp:dbus-ref
- namespace="org.freedesktop.Telepathy.Channel.Type"
- >ContactList</tp:dbus-ref> channel with TargetHandleType
- Handle_Type_List and TargetID 'deny'.</p>
- </tp:docstring>
-
- <method name="BlockContacts" tp:name-for-bindings="Block_Contacts">
- <tp:docstring xmlns="http://www.w3.org/1999/xhtml">
- <p>Direct the server to block some contacts. The precise effect is
- protocol-dependent, but SHOULD include ignoring all current and
- subsequent communications from the given contacts, avoiding sending
- presence to them in future, and if they were already receiving the
- local user's presence, behaving as if the local user went
- offline.</p>
-
- <p><em>FIXME: do we need to allow this on protocols where it won't
- persist, or where we can't edit the block lists?</em></p>
- </tp:docstring>
-
- <arg name="Contacts" type="au" direction="in" tp:type="Contact_Handle[]">
- <tp:docstring>Some contacts to block.</tp:docstring>
- </arg>
-
- <arg name="Report_Abusive" type="b" direction="in">
- <tp:docstring xmlns="http://www.w3.org/1999/xhtml">
- <p>In addition to blocking, report these contacts as abusive to the
- server administrators.</p>
-
- <p>Clients can determine whether this capability is available by
- checking the
- <tp:member-ref>ContactBlockingCapabilities</tp:member-ref>
- property. If the capability is not present and this argument is
- true, the error <tp:error-ref>NotCapable</tp:error-ref> SHOULD
- be raised.</p>
-
- <tp:rationale>
- Some protocol libraries, in their conformance requirements,
- require the ability to report blocked contacts as abusive.
- </tp:rationale>
- </tp:docstring>
- </arg>
-
- <tp:possible-errors>
- <tp:error name="org.freedesktop.Telepathy.Error.Disconnected"/>
- <tp:error name="org.freedesktop.Telepathy.Error.InvalidHandle"/>
- <tp:error name="org.freedesktop.Telepathy.Error.NetworkError"/>
- <tp:error name="org.freedesktop.Telepathy.Error.NotCapable"/>
- </tp:possible-errors>
- </method>
-
- <method name="UnblockContacts" tp:name-for-bindings="Unblock_Contacts">
- <tp:docstring xmlns="http://www.w3.org/1999/xhtml">
- <p>Reverse the effects of a previous call to
- <tp:member-ref>BlockContacts</tp:member-ref>.</p>
- </tp:docstring>
-
- <arg name="Contacts" type="au" direction="in" tp:type="Contact_Handle[]">
- <tp:docstring>Some contacts to unblock.</tp:docstring>
- </arg>
-
- <tp:possible-errors>
- <tp:error name="org.freedesktop.Telepathy.Error.Disconnected"/>
- <tp:error name="org.freedesktop.Telepathy.Error.InvalidHandle"/>
- <tp:error name="org.freedesktop.Telepathy.Error.NetworkError"/>
- </tp:possible-errors>
- </method>
-
- <method name="RequestBlockedContacts"
- tp:name-for-bindings="Request_Blocked_Contacts">
- <tp:docstring xmlns="http://www.w3.org/1999/xhtml">
- <p>List the contacts that are blocked.</p>
-
- <p>Clients SHOULD allow a relatively long timeout for calls to this
- method, since on some protocols contact blocking is part of the
- contact list, which can take a significant time to retrieve.</p>
- </tp:docstring>
-
- <arg name="Contacts" type="au" direction="out" tp:type="Contact_Handle[]">
- <tp:docstring>The list of blocked contacts.</tp:docstring>
- </arg>
-
- <tp:possible-errors>
- <tp:error name="org.freedesktop.Telepathy.Error.Disconnected"/>
- <tp:error name="org.freedesktop.Telepathy.Error.InvalidHandle"/>
- <tp:error name="org.freedesktop.Telepathy.Error.NetworkError"/>
- </tp:possible-errors>
- </method>
-
- <signal name="BlockedContactsChanged"
- tp:name-for-bindings="Blocked_Contacts_Changed">
- <tp:docstring xmlns="http://www.w3.org/1999/xhtml">
- <p>Emitted when the list of blocked contacts is first retrieved
- (before returning from any pending calls to
- <tp:member-ref>RequestBlockedContacts</tp:member-ref>), and
- whenever the list of blocked contacts subsequently changes.</p>
- </tp:docstring>
-
- <arg name="BlockedContacts" type="au" tp:type="Contact_Handle[]">
- <tp:docstring>Contacts added to the result of
- <tp:member-ref>RequestBlockedContacts</tp:member-ref>.</tp:docstring>
- </arg>
-
- <arg name="UnblockedContacts" type="au" tp:type="Contact_Handle[]">
- <tp:docstring>Contacts removed from the result of
- <tp:member-ref>RequestBlockedContacts</tp:member-ref>.</tp:docstring>
- </arg>
- </signal>
-
- <tp:contact-attribute name="blocked" type="b">
- <tp:docstring xmlns="http://www.w3.org/1999/xhtml">
- <p>True if the contact would be in the result of
- <tp:member-ref>RequestBlockedContacts</tp:member-ref>;
- False or omitted if the contact is not blocked, or if it is
- unknown whether the contact is blocked.</p>
- </tp:docstring>
- </tp:contact-attribute>
-
- <property name="ContactBlockingCapabilities"
- tp:name-for-bindings="Contact_Blocking_Capabilities"
- tp:type="Contact_Blocking_Capabilities" type="u" access="read"
- tp:immutable="yes">
- <tp:docstring xmlns="http://www.w3.org/1999/xhtml">
- <p>Additional capabilities for contact blocking (i.e. whether we can
- report abusive contacts).</p>
-
- <p><b>Note:</b> there is no capability for supporting blocking itself,
- the presence of this interface indicates that contact blocking is
- supported.</p>
- </tp:docstring>
- </property>
-
- <tp:flags name="Contact_Blocking_Capabilities" type="u"
- value-prefix="Contact_Blocking_Capability">
- <tp:flag suffix="Can_Report_Abusive" value="1">
- <tp:docstring>
- This protocol is capable of reporting abusive contacts to the server
- administrators.
- </tp:docstring>
- </tp:flag>
- </tp:flags>
-
- </interface>
-</node>
-<!-- vim:set sw=2 sts=2 et ft=xml: -->
diff --git a/extensions/Makefile.am b/extensions/Makefile.am
index 7182734a8..8a3b358fb 100644
--- a/extensions/Makefile.am
+++ b/extensions/Makefile.am
@@ -17,7 +17,6 @@ EXTRA_DIST = \
Authentication_TLS_Certificate.xml \
Channel_Interface_Credentials_Storage.xml \
Channel_Type_Server_TLS_Connection.xml \
- Connection_Interface_Contact_Blocking.xml \
$(NULL)
noinst_LTLIBRARIES = libemp-extensions.la
diff --git a/extensions/misc.xml b/extensions/misc.xml
index f977df64d..6a137ef06 100644
--- a/extensions/misc.xml
+++ b/extensions/misc.xml
@@ -9,6 +9,5 @@
<xi:include href="Authentication_TLS_Certificate.xml" />
<xi:include href="Channel_Interface_Credentials_Storage.xml" />
<xi:include href="Channel_Type_Server_TLS_Connection.xml" />
-<xi:include href="Connection_Interface_Contact_Blocking.xml" />
</tp:spec>
diff --git a/libempathy/empathy-tp-contact-list.c b/libempathy/empathy-tp-contact-list.c
index 30fb4a2d5..d947e7284 100644
--- a/libempathy/empathy-tp-contact-list.c
+++ b/libempathy/empathy-tp-contact-list.c
@@ -819,13 +819,13 @@ list_get_contact_blocking_capabilities_cb (TpProxy *conn,
{
EmpathyTpContactList *list = EMPATHY_TP_CONTACT_LIST (weak_object);
EmpathyTpContactListPriv *priv = GET_PRIV (list);
- EmpContactBlockingCapabilities caps;
+ TpContactBlockingCapabilities caps;
g_return_if_fail (G_VALUE_HOLDS_UINT (value));
caps = g_value_get_uint (value);
- if (caps & EMP_CONTACT_BLOCKING_CAPABILITY_CAN_REPORT_ABUSIVE) {
+ if (caps & TP_CONTACT_BLOCKING_CAPABILITY_CAN_REPORT_ABUSIVE) {
DEBUG ("Connection can report abusive contacts");
priv->flags |= EMPATHY_CONTACT_LIST_CAN_REPORT_ABUSIVE;
}
@@ -949,11 +949,11 @@ conn_ready_cb (TpConnection *connection,
/* Find out if we support reporting abusive contacts --
* this is done via the new Conn.I.ContactBlocking interface */
if (tp_proxy_has_interface_by_id (priv->connection,
- EMP_IFACE_QUARK_CONNECTION_INTERFACE_CONTACT_BLOCKING)) {
+ TP_IFACE_QUARK_CONNECTION_INTERFACE_CONTACT_BLOCKING)) {
DEBUG ("Have Conn.I.ContactBlocking");
tp_cli_dbus_properties_call_get (priv->connection, -1,
- EMP_IFACE_CONNECTION_INTERFACE_CONTACT_BLOCKING,
+ TP_IFACE_CONNECTION_INTERFACE_CONTACT_BLOCKING,
"ContactBlockingCapabilities",
list_get_contact_blocking_capabilities_cb,
NULL, NULL, G_OBJECT (list));
@@ -1371,8 +1371,8 @@ tp_contact_list_set_blocked (EmpathyContactList *list,
g_return_if_fail (priv->flags &
EMPATHY_CONTACT_LIST_CAN_REPORT_ABUSIVE);
- emp_cli_connection_interface_contact_blocking_call_block_contacts (
- TP_PROXY (priv->connection), -1,
+ tp_cli_connection_interface_contact_blocking_call_block_contacts (
+ priv->connection, -1,
&handles, TRUE, NULL, NULL, NULL, NULL);
} else if (blocked) {
tp_cli_channel_interface_group_call_add_members (