aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSjoerd Simons <sjoerd.simons@collabora.co.uk>2011-02-23 18:42:23 +0800
committerSjoerd Simons <sjoerd.simons@collabora.co.uk>2011-02-23 22:50:44 +0800
commit80e857fd3e975b1bd679dd9fc18ad7215ea322bc (patch)
tree8c929885a34bc78be1d024c5b8c0cc75b5d25807
parent5e556267aa25dd5eb4b82f0163cd5d5660d5473e (diff)
downloadgsoc2013-empathy-80e857fd3e975b1bd679dd9fc18ad7215ea322bc.tar
gsoc2013-empathy-80e857fd3e975b1bd679dd9fc18ad7215ea322bc.tar.gz
gsoc2013-empathy-80e857fd3e975b1bd679dd9fc18ad7215ea322bc.tar.bz2
gsoc2013-empathy-80e857fd3e975b1bd679dd9fc18ad7215ea322bc.tar.lz
gsoc2013-empathy-80e857fd3e975b1bd679dd9fc18ad7215ea322bc.tar.xz
gsoc2013-empathy-80e857fd3e975b1bd679dd9fc18ad7215ea322bc.tar.zst
gsoc2013-empathy-80e857fd3e975b1bd679dd9fc18ad7215ea322bc.zip
Don't use wildcards for just one marshal file
When a build is triggered from a location that isn't the top build dir, the generated files break as the wrong prefix gets passed for some reason. Given we only create one -marshal file, being smart doesn't actually save us anything, so do things the simple way
-rw-r--r--libempathy/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index c184fde44..9882d6a71 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -132,12 +132,12 @@ empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
mv $@.tmp $@; \
fi
-%-marshal.h: %-marshal.list Makefile
- $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
+empathy-marshal.h: empathy-marshal.list Makefile
+ $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_empathy_marshal $< > empathy-marshal.h
-%-marshal.c: %-marshal.list Makefile
+empathy-marshal.c: empathy-marshal.list Makefile
$(AM_V_GEN)echo "#include \"empathy-marshal.h\"" > $@ && \
- $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
+ $(GLIB_GENMARSHAL) --body --prefix=_empathy_marshal $< >> empathy-marshal.c
empathy-enum-types.h: stamp-empathy-enum-types.h
$(AM_V_GEN)true