aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanielle Madeley <danielle.madeley@collabora.co.uk>2011-03-10 14:05:28 +0800
committerDanielle Madeley <danielle.madeley@collabora.co.uk>2011-03-14 18:46:47 +0800
commitc8d64afdedb44aa11e30f945dd568052726e685c (patch)
tree0659c22033ab412b18aac8c9f190c2c781fe744d
parentf66047550d0d3c3777b9d924b281e7eeee8786bb (diff)
downloadgsoc2013-empathy-c8d64afdedb44aa11e30f945dd568052726e685c.tar
gsoc2013-empathy-c8d64afdedb44aa11e30f945dd568052726e685c.tar.gz
gsoc2013-empathy-c8d64afdedb44aa11e30f945dd568052726e685c.tar.bz2
gsoc2013-empathy-c8d64afdedb44aa11e30f945dd568052726e685c.tar.lz
gsoc2013-empathy-c8d64afdedb44aa11e30f945dd568052726e685c.tar.xz
gsoc2013-empathy-c8d64afdedb44aa11e30f945dd568052726e685c.tar.zst
gsoc2013-empathy-c8d64afdedb44aa11e30f945dd568052726e685c.zip
Add Account.Interface.ExternalPasswordStorage to extensions
-rw-r--r--extensions/Account_Interface_External_Password_Storage.xml52
-rw-r--r--extensions/Makefile.am1
-rw-r--r--extensions/misc.xml1
3 files changed, 54 insertions, 0 deletions
diff --git a/extensions/Account_Interface_External_Password_Storage.xml b/extensions/Account_Interface_External_Password_Storage.xml
new file mode 100644
index 000000000..71a542428
--- /dev/null
+++ b/extensions/Account_Interface_External_Password_Storage.xml
@@ -0,0 +1,52 @@
+<?xml version="1.0" ?>
+<node name="/Account_Interface_External_Password_Storage"
+ xmlns:tp="http://telepathy.freedesktop.org/wiki/DbusSpec#extensions-v0">
+
+ <tp:copyright>Copyright © 2011 Collabora Ltd.</tp:copyright>
+ <tp:license xmlns="http://www.w3.org/1999/xhtml">
+ <p>This library is free software; you can redistribute it and/or
+ modify it under the terms of the GNU Lesser General Public
+ License as published by the Free Software Foundation; either
+ version 2.1 of the License, or (at your option) any later version.</p>
+
+ <p>This library is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ Lesser General Public License for more details.</p>
+
+ <p>You should have received a copy of the GNU Lesser General Public
+ License along with this library; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+ 02110-1301, USA.</p>
+ </tp:license>
+
+ <interface name="org.freedesktop.Telepathy.Account.Interface.ExternalPasswordStorage.DRAFT"
+ tp:causes-havoc="experimental">
+ <tp:added version="0.21.10">(draft 1)</tp:added>
+ <tp:requires interface="org.freedesktop.Telepathy.Account"/>
+
+ <tp:docstring xmlns="http://www.w3.org/1999/xhtml">
+ <p>An interface for Accounts whose passwords are stored externally and
+ SHOULD NOT be stored by either the <tp:dbus-ref
+ namespace="org.freedesktop.Telepathy">AccountManager</tp:dbus-ref> nor
+ any <tp:dbus-ref
+ namespace="org.freedesktop.Telepathy.Channel.Type">ServerAuthentication</tp:dbus-ref>
+ handler.</p>
+ </tp:docstring>
+
+ <method name="ForgetPassword" tp:name-for-bindings="Forget_Password">
+ <tp:docstring>
+ <p>Clears any saved password associated with this account.</p>
+ </tp:docstring>
+ </method>
+
+ <property name="PasswordSaved"
+ tp:name-for-bindings="Password_Saved"
+ type="b" access="read">
+ <tp:docstring>
+ <p>Indicates whether the account has a saved password or not.</p>
+ </tp:docstring>
+ </property>
+
+ </interface>
+</node>
diff --git a/extensions/Makefile.am b/extensions/Makefile.am
index 37d469d1b..c7d15e9da 100644
--- a/extensions/Makefile.am
+++ b/extensions/Makefile.am
@@ -14,6 +14,7 @@ EXTRA_DIST = \
misc.xml \
Debug.xml \
Logger.xml \
+ Account_Interface_External_Password_Storage.xml \
Authentication_TLS_Certificate.xml \
Channel_Interface_Credentials_Storage.xml \
Channel_Type_Server_TLS_Connection.xml \
diff --git a/extensions/misc.xml b/extensions/misc.xml
index 579f6ec9a..f689becce 100644
--- a/extensions/misc.xml
+++ b/extensions/misc.xml
@@ -6,6 +6,7 @@
<xi:include href="Debug.xml" />
<xi:include href="Logger.xml" />
+<xi:include href="Account_Interface_External_Password_Storage.xml" />
<xi:include href="Authentication_TLS_Certificate.xml" />
<xi:include href="Channel_Interface_Credentials_Storage.xml" />
<xi:include href="Channel_Type_Server_TLS_Connection.xml" />