aboutsummaryrefslogtreecommitdiffstats
path: root/crypto/key_store_passphrase.go
Commit message (Collapse)AuthorAgeFilesLines
* accounts, crypto: move keystore to package accountsFelix Lange2016-04-121-315/+0
| | | | | | | | | | The account management API was originally implemented as a thin layer around crypto.KeyStore, on the grounds that several kinds of key stores would be implemented later on. It turns out that this won't happen so KeyStore is a superflous abstraction. In this commit crypto.KeyStore and everything related to it moves to package accounts and is unexported.
* crypto: expose key encryption method, add ping-pong testPéter Szilágyi2016-02-241-18/+20
|
* crypto: code polish + ensure key file contents match with namePéter Szilágyi2016-02-241-5/+12
|
* crypto: expose key decryption method to parse a string direcltyPéter Szilágyi2016-02-241-26/+37
|
* all: Rename crypto.Sha3{,Hash}() to crypto.Keccak256{,Hash}()Ricardo Catalinas Jiménez2016-02-221-4/+4
| | | | As we aren't really using the standarized SHA-3
* cmd/utils, crypto: add --lightkdf flag for lighter KDFDrake Burroughs2015-10-291-13/+22
|
* Change go-uuid to use the current supported repository.Jeff R. Allen2015-09-121-1/+1
|
* all: fix license headers one more timeFelix Lange2015-07-241-1/+1
| | | | I forgot to update one instance of "go-ethereum" in commit 3f047be5a.
* all: update license headers to distiguish GPL/LGPLFelix Lange2015-07-231-4/+4
| | | | | All code outside of cmd/ is licensed as LGPL. The headers now reflect this by calling the whole work "the go-ethereum library".
* crypto: remove debug print call after decrypting a key from diskFelix Lange2015-07-211-1/+0
|
* all: remove @author commentsFelix Lange2015-07-071-7/+0
|
* all: update license informationFelix Lange2015-07-071-15/+15
|
* account update: migrate or change passwordzelig2015-07-031-15/+18
| | | | | | * account.Update * KeyStore.Cleanup * fix dir rm for old format deleteKey
* fix account orderingzelig2015-07-031-19/+15
| | | | | | | | * chronological order of creation * new naming scheme keystore/UTC--<created_at UTC ISO8601>-<address hex> * KeyStore2 -> KeyStore * backward compatibility * refactor keyStore methods
* Change keystore to version 3Gustav Simonsson2015-06-241-72/+119
| | | | | | | | | | | | * Change password protection crypto in keystore to version 3 * Update KeyStoreTests/basic_tests.json * Add support for PBKDF2 with HMAC-SHA256 * Change MAC and encryption key to avoid unnecessary hashing * Add tests for test vectors in new wiki page defining version 3 * Add tests for new keystore tests in ethereum/tests repo * Move JSON loading util to common for use in both tests and crypto packages * Add backwards compatibility with key store version 1
* Update keystore code commentsGustav Simonsson2015-05-141-6/+7
|
* Update key store to new spec but keep address field for nowGustav Simonsson2015-05-121-42/+29
| | | | * Also fix address types post-rebase
* Address pull request comments; key header and hex encodingGustav Simonsson2015-05-121-12/+30
| | | | | | * Remove key header from unencrypted key file format and replace it with a version field * Change encoding of bytes in key files from base64 to hex
* Revert "Add key header to unencrypted key file"Gustav Simonsson2015-05-121-4/+3
| | | | This reverts commit a94d4ba0b53c4558ab838aaed635a2ff66ddfa53.
* Add key header to unencrypted key fileGustav Simonsson2015-05-121-3/+4
|
* Add key header to encrypted keysGustav Simonsson2015-05-121-3/+38
| | | | | | | * Add key header containing key version, kdf and kdf params * Store key header as JSON in the key file * Read in KDF params from key header * Include key header in MAC calculation and MAC verification
* Use common.Address type for accounts.AddressGustav Simonsson2015-05-121-7/+7
|
* Improve key store passphrase cryptoGustav Simonsson2015-05-121-21/+28
| | | | | | | * Change MAC-then-Encrypt to Encrypt-then-MAC * Change AES256 to AES128 * Use first 16 bytes of KDF derived key for AES and remaining 16 for MAC
* Remove the awesome, ever misunderstood entropy mixingGustav Simonsson2015-05-121-2/+2
|
* replaced several path.* with filepath.* which is platform independentBas van Kervel2015-05-121-2/+2
|
* crypto: switch to golang.org/x/cryptoFelix Lange2015-02-171-3/+5
| | | | | code.google.com/p/go.crypto is deprecated and will cause problems in future versions of Go.
* Set both key generation and ECDSA nonce to use mixed entropyGustav Simonsson2015-02-111-12/+3
| | | | | | * Move random entropy functions to new package randentropy * Add function to get n bytes entropy where up to first 32 bytes are mixed with OS entropy sources
* Address pull request commentsGustav Simonsson2015-01-281-3/+3
| | | | | | | | | * Use crypto.Sign instead of directly calling secp256k1 lib * Rename UserAccount to Account and Addr to Address (for consistency) * Change AccountManager.Sign to take ptr to Account instead of address byte array * Simplify copying of Accounts in Accounts() * PubkeyToAddress and GetEntropyCSPRNG now exported
* Add accounts package and refactor key storesGustav Simonsson2015-01-261-17/+23
| | | | | | | | * Add initial UserAccount and AccountManager structs * Add NewAccount, Sign and Accounts functions * Refactor key stores to use key address as main identifier while keeping the UUID. * Use key address as file/dir names instead of UUID
* CamelCase aesCBCDecryptGustav Simonsson2015-01-221-1/+1
|
* Add ImportPreSaleKeyGustav Simonsson2015-01-211-45/+1
| | | | | | * ImportPreSaleKey takes a KeyStore, a presale key JSON (e.g. file content) and a password string. It stores the key in the given key store. * Refactored common AES decryption and moved some functions to crypto.go
* Address pull request commentsGustav Simonsson2015-01-201-6/+3
| | | | | * Further simplify "constructor" function's allocation of structs * Fix formatting
* Address pull request commentsGustav Simonsson2015-01-201-5/+7
| | | | | * Allocate with composite literal instead of new * Remove check of number of bytes read from rand
* Update code commentsGustav Simonsson2015-01-161-6/+4
|
* Address pull request commentsGustav Simonsson2015-01-161-40/+35
| | | | | | | | * Remove flags field from key struct * Change JSON struct fields from string to []byte * Change GenerateNewKey API to take io.Reader for random source * Remove mixing entropy source function * Use testing Fatal in tests
* Address pull request commentsGustav Simonsson2015-01-161-0/+253
* Simplify scrypt constants with const block * Add key store constructors and make their types private * Simplify key store and file namings to be less Java Enterprise™ * Change test error logging to use t.Error(err) * Reduce number of naked returns (just like my ex-gf) * Simplify file reading path code