aboutsummaryrefslogtreecommitdiffstats
path: root/accounts/accounts_test.go
Commit message (Collapse)AuthorAgeFilesLines
* accounts, cmd, eth, internal, mobile, node: split account backendsPéter Szilágyi2017-02-131-224/+0
|
* accounts, mobile: make account manager API a bit more uniformPéter Szilágyi2017-01-171-4/+4
|
* all: fix ineffectual assignments and remove uses of crypto.Sha3Felix Lange2017-01-091-0/+6
| | | | | go get github.com/gordonklaus/ineffassign ineffassign .
* accounts, internal, mobile: polish accounts API, extend Android testsPéter Szilágyi2017-01-051-2/+2
|
* eth: add new RPC method (personal.) SignAndSendTransactionBas van Kervel2016-05-201-0/+28
|
* accounts: ensure TimedUnlock does not override indefinite unlock timeoutFelix Lange2016-04-121-2/+2
|
* accounts: improve API and add documentationFelix Lange2016-04-121-10/+10
| | | | | - Sign takes common.Address, not Account - Import/Export methods work with encrypted JSON keys
* accounts: cache key addressesFelix Lange2016-04-121-6/+48
| | | | | | | | | | | | | | | In order to avoid disk thrashing for Accounts and HasAccount, address->key file mappings are now cached in memory. This makes it no longer necessary to keep the key address in the file name. The address of each key is derived from file content instead. There are minor user-visible changes: - "geth account list" now reports key file paths alongside the address. - If multiple keys are present for an address, unlocking by address is not possible. Users are directed to remove the duplicate files instead. Unlocking by index is still possible. - Key files are overwritten written in place when updating the password.
* accounts: streamline APIFelix Lange2016-04-121-5/+5
| | | | | | - Manager.Accounts no longer returns an error. - Manager methods take Account instead of common.Address. - All uses of Account with unkeyed fields are converted.
* accounts: fix go vet warningsFelix Lange2016-04-121-1/+1
|
* accounts, crypto: move keystore to package accountsFelix Lange2016-04-121-11/+9
| | | | | | | | | | The account management API was originally implemented as a thin layer around crypto.KeyStore, on the grounds that several kinds of key stores would be implemented later on. It turns out that this won't happen so KeyStore is a superflous abstraction. In this commit crypto.KeyStore and everything related to it moves to package accounts and is unexported.
* accounts: increase re-lock timeout to account for slow CI serversPéter Szilágyi2015-12-011-1/+1
|
* Merge pull request #1548 from fjl/accounts-test-deflakeJeffrey Wilcke2015-08-031-1/+2
|\ | | | | accounts: bump timeout in TestSignRace
| * accounts: bump timeout and spin less in TestSignRaceFelix Lange2015-08-021-1/+2
| | | | | | | | This should fix the flakeyness.
* | all: fix license headers one more timeFelix Lange2015-07-241-1/+1
|/ | | | I forgot to update one instance of "go-ethereum" in commit 3f047be5a.
* all: update license headers to distiguish GPL/LGPLFelix Lange2015-07-231-4/+4
| | | | | All code outside of cmd/ is licensed as LGPL. The headers now reflect this by calling the whole work "the go-ethereum library".
* accounts: fix data race when key is locked after the unlock timeoutFelix Lange2015-07-211-15/+37
| | | | | | While here, also improve the docs and speed up the tests. The tests used the scrypt keystore with ridiculous settins and took 20s each.
* all: update license informationFelix Lange2015-07-071-0/+16
|
* fix account orderingzelig2015-07-031-2/+3
| | | | | | | | * chronological order of creation * new naming scheme keystore/UTC--<created_at UTC ISO8601>-<address hex> * KeyStore2 -> KeyStore * backward compatibility * refactor keyStore methods
* unlock multiple passes and obsolete primaryzelig2015-07-031-1/+1
| | | | | | | * multiple passwords allowed in password file * split on "\n", sideeffect: chop trailing slashes. fixes common mistake <(echo 'pass') * remove accounts.Primary method * do not fall back to primary account for mining
* simplify account unlockingzelig2015-07-031-1/+42
|
* accounts: add {Timed,}Unlock, remove SignLockedFelix Lange2015-03-101-38/+24
|
* accounts: AccountManager -> ManagerFelix Lange2015-03-081-2/+2
|
* accounts: use time.Duration correctlyFelix Lange2015-03-081-4/+4
| | | | | | | There is no point to using time.Duration if the value is interpreted as milliseconds. Callers should use the standard multiplication idiom to choose the unit. In fact, the only caller outside of the tests already does so.
* accounts: use pointers consistentlyFelix Lange2015-03-081-1/+2
| | | | | | | | Account is now always a non-pointer. This will be important once the manager starts remembering accounts. AccountManager is now always a pointer because it contains locks and locks cannot be copied.
* Address pull request commentsGustav Simonsson2015-02-261-1/+1
| | | | | | * Use RWMutex instead of Mutex * Use time.Duration instead of int for unlock time * Use time.After with select instead of time.Sleep
* Add automatic locking / unlocking of accountsGustav Simonsson2015-02-261-2/+51
| | | | | | | * Change account signing API to two sign functions; Sign without passphrase - works if account is unlocked Sign with passphrase - always works and unlocks the account * Account stays unlocked for X ms and is then automatically locked
* Fix key store address hex decoding and accounts testGustav Simonsson2015-02-251-1/+13
| | | | Thanks to https://github.com/jaekwon for original fix!
* Implement OS sensitive dataDirsMaran2015-02-231-1/+2
|
* accounts: use crypto/randentropy in testFelix Lange2015-02-201-2/+4
|
* Address pull request commentsGustav Simonsson2015-01-281-3/+2
| | | | | | | | | * Use crypto.Sign instead of directly calling secp256k1 lib * Rename UserAccount to Account and Addr to Address (for consistency) * Change AccountManager.Sign to take ptr to Account instead of address byte array * Simplify copying of Accounts in Accounts() * PubkeyToAddress and GetEntropyCSPRNG now exported
* Add accounts package and refactor key storesGustav Simonsson2015-01-261-0/+19
* Add initial UserAccount and AccountManager structs * Add NewAccount, Sign and Accounts functions * Refactor key stores to use key address as main identifier while keeping the UUID. * Use key address as file/dir names instead of UUID