| Commit message (Collapse) | Author | Age | Files | Lines |
... | |
| |
|
| |
|
| |
|
| |
|
|\
| |
| | |
accounts/abi: Fixed bytes input accept []byte and variable input support
|
| |
| |
| |
| |
| |
| |
| |
| |
| | |
Fixed up `[]byte` slice support such that `function print(bytes input)`
accepts `[]byte` as input and treats it as 1 element rather than a slice
of multiple elements.
Added support for variable length input parameters like `bytes` and
`strings`.
|
|/ |
|
|
|
|
| |
As we aren't really using the standarized SHA-3
|
|
|
|
|
| |
Added support for fixed size and arbitrary length byte arrays to be
marshallable in fixed size (typed) byte slices.
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
Removed old unmarshalling of return types: `abi.Call(...).([]byte)`.
This is now replaced by a new syntax:
```
var a []byte
err := abi.Call(&a, ...)
```
It also addresses a few issues with Bytes and Strings and can also
handle both fixed and arbitrary sized byte slices, including strings.
|
|
|
|
|
|
| |
Implementation of basic event parsing and its input types. This
separates methods and events and fixes an issue with go type parsing and
validation.
|
| |
|
|\
| |
| | |
rpc: new RPC implementation with pub/sub support
|
| | |
|
|\ \
| |/
|/| |
accounts/abi: added output parsing & added call mechanism
|
| |
| |
| |
| | |
Added calling mechanism and return value parsing
|
|/ |
|
|
|
|
|
|
|
| |
Changed field `input` to new `inputs`. Addad Hash and Address as input
types.
Added bytes[N] and N validation
|
|\
| |
| | |
accounts: bump timeout in TestSignRace
|
| |
| |
| |
| | |
This should fix the flakeyness.
|
|/
|
|
| |
I forgot to update one instance of "go-ethereum" in commit 3f047be5a.
|
|
|
|
|
| |
All code outside of cmd/ is licensed as LGPL. The headers
now reflect this by calling the whole work "the go-ethereum library".
|
|
|
|
|
|
| |
While here, also improve the docs and speed up the tests.
The tests used the scrypt keystore with ridiculous settins and took 20s
each.
|
| |
|
| |
|
| |
|
| |
|
|
|
|
|
|
| |
* account.Update
* KeyStore.Cleanup
* fix dir rm for old format deleteKey
|
|
|
|
|
|
|
|
| |
* chronological order of creation
* new naming scheme keystore/UTC--<created_at UTC ISO8601>-<address hex>
* KeyStore2 -> KeyStore
* backward compatibility
* refactor keyStore methods
|
|
|
|
|
|
|
| |
* multiple passwords allowed in password file
* split on "\n", sideeffect: chop trailing slashes. fixes common mistake <(echo 'pass')
* remove accounts.Primary method
* do not fall back to primary account for mining
|
| |
|
| |
|
| |
|
|
|
|
|
|
|
|
| |
- etherbase flag for block reward destination
- coinbase => etherbase
- CLI- eth Config -> eth, xeth -> RPC / Miner
- use primary instead of coinbase as the unlock magic wildcard
- accounts: firstAddr/Coinbase -> Primary
|
|
|
|
|
|
|
| |
- remove account export functionality from CLI
- remove accountExport method,
- remove unencrypted-keys flag from everywhere
- improve documentation
|
|
|
|
|
| |
- accounts: remove Manager.getKey
- cli: for -unlock coinbase, use account manager Coinbase()
|
| |
|
|
|
|
|
| |
- extract accounts.getKey method - if given empty address it retrieves coinbase (first account)
- cli -unlock coinbase will unlock coinbase
|
|
|
|
|
|
|
|
|
|
|
| |
- cli: add passwordfile flag
- cli: change unlock flag only takes account
- cli: with unlock you are prompted for password or use passfile with password flag
- cli: unlockAccount used in normal client start (run) and accountExport
- cli: getPassword used in accountCreate and accountImport
- accounts: Manager.Import, Manager.Export
- crypto: SaveECDSA (to complement LoadECDSA) to save to file
- crypto: NewKeyFromECDSA added (used in accountImport and New = generated constructor)
|
| |
|
| |
|
| |
|
|\
| |
| |
| |
| |
| |
| |
| |
| |
| | |
Conflicts:
cmd/utils/cmd.go
cmd/utils/flags.go
core/manager.go
eth/backend.go
rpc/http/server.go
xeth/xeth.go
|
| | |
|
| | |
|
| |
| |
| |
| | |
This was suggested during review.
|
| | |
|
| |
| |
| |
| |
| | |
Private keys would be locked early if SignLocked was called more than
once because the unlockLater was still running. Terminate it properly.
|
| |
| |
| |
| |
| | |
RWMutexes must be write-locked when writing in order
to actually protect the writes.
|
| |
| |
| |
| |
| |
| |
| | |
There is no point to using time.Duration if the value is interpreted as
milliseconds. Callers should use the standard multiplication idiom to
choose the unit. In fact, the only caller outside of the tests already
does so.
|
| |
| |
| |
| |
| |
| |
| |
| | |
Account is now always a non-pointer. This will be important once
the manager starts remembering accounts.
AccountManager is now always a pointer because it contains locks
and locks cannot be copied.
|
|/
|
|
|
| |
The account manager is now responsible for picking the
default account and the coinbase.
|
|\
| |
| |
| |
| | |
Conflicts:
accounts/account_manager.go
|
| | |
|
| |
| |
| |
| |
| |
| | |
* Use RWMutex instead of Mutex
* Use time.Duration instead of int for unlock time
* Use time.After with select instead of time.Sleep
|
| |
| |
| |
| |
| |
| |
| | |
* Change account signing API to two sign functions;
Sign without passphrase - works if account is unlocked
Sign with passphrase - always works and unlocks the account
* Account stays unlocked for X ms and is then automatically locked
|
|/ |
|
|
|
|
| |
Thanks to https://github.com/jaekwon for original fix!
|
| |
|
| |
|
|\
| |
| |
| | |
https://github.com/Gustav-Simonsson/go-ethereum into Gustav-Simonsson-key_store_and_accounts_integration
|
| |
| |
| |
| |
| |
| |
| |
| |
| | |
* Use crypto.Sign instead of directly calling secp256k1 lib
* Rename UserAccount to Account and Addr to Address (for consistency)
* Change AccountManager.Sign to take ptr to Account instead of
address byte array
* Simplify copying of Accounts in Accounts()
* PubkeyToAddress and GetEntropyCSPRNG now exported
|
|/ |
|
|
* Add initial UserAccount and AccountManager structs
* Add NewAccount, Sign and Accounts functions
* Refactor key stores to use key address as main identifier
while keeping the UUID.
* Use key address as file/dir names instead of UUID
|