aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorPaweł Bylica <chfast@gmail.com>2015-08-25 21:38:41 +0800
committerPaweł Bylica <chfast@gmail.com>2015-08-25 21:38:41 +0800
commite4858023be33ad1b5e1a43b91c1b5e2d6251b8ea (patch)
treec972b697d071434995f27c8d03d9a11a2e23c8e3 /test/CMakeLists.txt
parent40e65295ffc4678d5d316eb7c5243858e4822f7b (diff)
downloaddexon-solidity-e4858023be33ad1b5e1a43b91c1b5e2d6251b8ea.tar
dexon-solidity-e4858023be33ad1b5e1a43b91c1b5e2d6251b8ea.tar.gz
dexon-solidity-e4858023be33ad1b5e1a43b91c1b5e2d6251b8ea.tar.bz2
dexon-solidity-e4858023be33ad1b5e1a43b91c1b5e2d6251b8ea.tar.lz
dexon-solidity-e4858023be33ad1b5e1a43b91c1b5e2d6251b8ea.tar.xz
dexon-solidity-e4858023be33ad1b5e1a43b91c1b5e2d6251b8ea.tar.zst
dexon-solidity-e4858023be33ad1b5e1a43b91c1b5e2d6251b8ea.zip
Fix "add_sources" cmake macro.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index a7e27414..25120c89 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -2,8 +2,10 @@ cmake_policy(SET CMP0015 NEW)
aux_source_directory(. SRC_LIST)
+get_filename_component(TESTS_DIR "${CMAKE_CURRENT_SOURCE_DIR}" ABSOLUTE)
+
macro (add_sources)
- file (RELATIVE_PATH _relPath "${CMAKE_SOURCE_DIR}/test" "${CMAKE_CURRENT_SOURCE_DIR}")
+ file (RELATIVE_PATH _relPath ${TESTS_DIR} ${CMAKE_CURRENT_SOURCE_DIR})
foreach (_src ${ARGN})
if (_relPath)
list (APPEND SRC "${_relPath}/${_src}")