aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBob Summerwill <bob@summerwill.net>2016-08-01 13:25:37 +0800
committerBob Summerwill <bob@summerwill.net>2016-08-01 16:45:11 +0800
commit4ee2114127f87b08b76b3ca94cde80a49cdc056a (patch)
treeb680926d0da4aadfddae0db9567557802f2c2929 /test/CMakeLists.txt
parent56727d61a61e1485c8360f00700d766632ec7163 (diff)
downloaddexon-solidity-4ee2114127f87b08b76b3ca94cde80a49cdc056a.tar
dexon-solidity-4ee2114127f87b08b76b3ca94cde80a49cdc056a.tar.gz
dexon-solidity-4ee2114127f87b08b76b3ca94cde80a49cdc056a.tar.bz2
dexon-solidity-4ee2114127f87b08b76b3ca94cde80a49cdc056a.tar.lz
dexon-solidity-4ee2114127f87b08b76b3ca94cde80a49cdc056a.tar.xz
dexon-solidity-4ee2114127f87b08b76b3ca94cde80a49cdc056a.tar.zst
dexon-solidity-4ee2114127f87b08b76b3ca94cde80a49cdc056a.zip
Make the Solidity repository standalone.
This commit is the culmination of several months of work to decouple Solidity from the webthree-umbrella so that it can be developed in parallel with cpp-ethereum (the Ethereum C++ runtime) and so that even for the Solidity unit-tests there is no hard-dependency onto the C++ runtime. The Tests-over-IPC refactoring was a major step in the same process which was already committed. This commit contains the following changes: - A subset of the CMake functionality in webthree-helpers was extracted and tailored for Solidity into ./cmake. Further cleanup is certainly possible. - A subset of the libdevcore functionality in libweb3core was extracted and tailored for Solidity into ./libdevcore. Further cleanup is certainly possible - The gas price constants in EVMSchedule were orphaned into libevmasm. - Some other refactorings and cleanups were made to sever unnecessary EVM dependencies in the Solidity unit-tests. - TravisCI and Appveyor support was added, covering builds and running of the unit-tests (Linux and macOS only for now) - A bug-fix was made to get the Tests-over-IPC running on macOS. - There are still reliability issues in the unit-tests, which need immediate attention. The Travis build has been flipped to run the unit-tests 5 times, to try to flush these out. - The Emscripten automation which was previously in webthree-umbrella was merged into the TravisCI automation here. - The development ZIP deployment step has been commented out, but we will want to read that ONLY for release branch. Further iteration on these changes will definitely be needed, but I feel these have got to sufficient maturity than holding them back further isn't winning us anything. It is go time :-)
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index efcbb82e..2f001b21 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -26,7 +26,7 @@ file(GLOB HEADERS "*.h" "*/*.h")
set(EXECUTABLE soltest)
eth_simple_add_executable(${EXECUTABLE} ${SRC_LIST} ${HEADERS})
-eth_use(${EXECUTABLE} REQUIRED Solidity::solidity Eth::ethcore)
+eth_use(${EXECUTABLE} REQUIRED Solidity::solidity)
include_directories(BEFORE ..)
target_link_libraries(${EXECUTABLE} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARIES})