aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Beregszaszi <alex@rtfs.hu>2017-09-16 10:50:16 +0800
committerAlex Beregszaszi <alex@rtfs.hu>2017-12-11 20:49:08 +0800
commit1734d4456189b4a313a07e7f3e24cb01f5057fc3 (patch)
tree3cbc303365f827a8c7f76cb7feb6eabfa821c9c7 /test/CMakeLists.txt
parent27f38fb5b31b9f0c228238cf0471155498b951b7 (diff)
downloaddexon-solidity-1734d4456189b4a313a07e7f3e24cb01f5057fc3.tar
dexon-solidity-1734d4456189b4a313a07e7f3e24cb01f5057fc3.tar.gz
dexon-solidity-1734d4456189b4a313a07e7f3e24cb01f5057fc3.tar.bz2
dexon-solidity-1734d4456189b4a313a07e7f3e24cb01f5057fc3.tar.lz
dexon-solidity-1734d4456189b4a313a07e7f3e24cb01f5057fc3.tar.xz
dexon-solidity-1734d4456189b4a313a07e7f3e24cb01f5057fc3.tar.zst
dexon-solidity-1734d4456189b4a313a07e7f3e24cb01f5057fc3.zip
Rename jsonCompiler to libsolc
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 6a8a4399..f36ad4c5 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -3,7 +3,7 @@ list(REMOVE_ITEM sources "${CMAKE_CURRENT_SOURCE_DIR}/fuzzer.cpp")
file(GLOB_RECURSE headers "*.h")
add_executable(soltest ${sources} ${headers})
-target_link_libraries(soltest PRIVATE soljson solidity lll evmasm devcore ${Boost_UNIT_TEST_FRAMEWORK_LIBRARIES})
+target_link_libraries(soltest PRIVATE libsolc solidity lll evmasm devcore ${Boost_UNIT_TEST_FRAMEWORK_LIBRARIES})
add_executable(solfuzzer fuzzer.cpp)
-target_link_libraries(solfuzzer soljson evmasm ${Boost_PROGRAM_OPTIONS_LIBRARIES})
+target_link_libraries(solfuzzer PRIVATE libsolc evmasm ${Boost_PROGRAM_OPTIONS_LIBRARIES})