aboutsummaryrefslogtreecommitdiffstats
path: root/solc/CMakeLists.txt
diff options
context:
space:
mode:
authorPaweł Bylica <chfast@gmail.com>2017-08-23 04:50:03 +0800
committerPaweł Bylica <chfast@gmail.com>2017-08-23 04:50:25 +0800
commit4974ff3962759a19150877b0e59e64319190ba1d (patch)
treec0a96c8d0037de5ef64c44d33a7683598216970d /solc/CMakeLists.txt
parent15fd43f0357e1f3c6ec1262df6ee39b06a6fe3f9 (diff)
downloaddexon-solidity-4974ff3962759a19150877b0e59e64319190ba1d.tar
dexon-solidity-4974ff3962759a19150877b0e59e64319190ba1d.tar.gz
dexon-solidity-4974ff3962759a19150877b0e59e64319190ba1d.tar.bz2
dexon-solidity-4974ff3962759a19150877b0e59e64319190ba1d.tar.lz
dexon-solidity-4974ff3962759a19150877b0e59e64319190ba1d.tar.xz
dexon-solidity-4974ff3962759a19150877b0e59e64319190ba1d.tar.zst
dexon-solidity-4974ff3962759a19150877b0e59e64319190ba1d.zip
CMake: Add option to static link solc
Diffstat (limited to 'solc/CMakeLists.txt')
-rw-r--r--solc/CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/solc/CMakeLists.txt b/solc/CMakeLists.txt
index 0563fe2a..656b27c3 100644
--- a/solc/CMakeLists.txt
+++ b/solc/CMakeLists.txt
@@ -16,4 +16,16 @@ if (EMSCRIPTEN)
else()
add_library(soljson jsonCompiler.cpp)
endif()
-target_link_libraries(soljson PRIVATE solidity) \ No newline at end of file
+target_link_libraries(soljson PRIVATE solidity)
+
+if(SOLC_LINK_STATIC AND UNIX AND NOT APPLE)
+ # Produce solc as statically linked binary (includes C/C++ standard libraries)
+ # This is not supported on macOS, see
+ # https://developer.apple.com/library/content/qa/qa1118/_index.html.
+ set_target_properties(
+ solc PROPERTIES
+ LINK_FLAGS -static
+ LINK_SEARCH_START_STATIC ON
+ LINK_SEARCH_END_STATIC ON
+ )
+endif() \ No newline at end of file