aboutsummaryrefslogtreecommitdiffstats
path: root/solc/CMakeLists.txt
diff options
context:
space:
mode:
authorchriseth <c@ethdev.com>2015-10-16 01:18:14 +0800
committerchriseth <c@ethdev.com>2015-10-16 01:18:14 +0800
commit370b6db3aef549b10c156098cb4bfb8238da7f18 (patch)
treec70b2cfddd6393ef626c55e0904b63e8db95c82f /solc/CMakeLists.txt
parentcb869fd5a447fc70b8c43f14f234316b0898485c (diff)
downloaddexon-solidity-370b6db3aef549b10c156098cb4bfb8238da7f18.tar
dexon-solidity-370b6db3aef549b10c156098cb4bfb8238da7f18.tar.gz
dexon-solidity-370b6db3aef549b10c156098cb4bfb8238da7f18.tar.bz2
dexon-solidity-370b6db3aef549b10c156098cb4bfb8238da7f18.tar.lz
dexon-solidity-370b6db3aef549b10c156098cb4bfb8238da7f18.tar.xz
dexon-solidity-370b6db3aef549b10c156098cb4bfb8238da7f18.tar.zst
dexon-solidity-370b6db3aef549b10c156098cb4bfb8238da7f18.zip
Do not forget to export the new symbol.
Diffstat (limited to 'solc/CMakeLists.txt')
-rw-r--r--solc/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/solc/CMakeLists.txt b/solc/CMakeLists.txt
index 40ab0e21..7dd24627 100644
--- a/solc/CMakeLists.txt
+++ b/solc/CMakeLists.txt
@@ -18,7 +18,7 @@ else()
endif()
if (EMSCRIPTEN)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -s EXPORTED_FUNCTIONS='[\"_compileJSON\",\"_version\"]'")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -s EXPORTED_FUNCTIONS='[\"_compileJSON\",\"_version\",\"_compileJSONMulti\"]'")
add_executable(soljson jsonCompiler.cpp ${HEADERS})
eth_use(soljson REQUIRED Solidity)
else()