aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorchriseth <c@ethdev.com>2015-04-22 17:30:33 +0800
committerchriseth <c@ethdev.com>2015-04-24 20:50:14 +0800
commited096881b97222357ac636b41eb21e20225beaf1 (patch)
treec07608b28b57a42c84759738ccb80b1526169473 /CMakeLists.txt
parentd99247cb5dd34d49e23f09cd78a9618cfafab466 (diff)
downloaddexon-solidity-ed096881b97222357ac636b41eb21e20225beaf1.tar
dexon-solidity-ed096881b97222357ac636b41eb21e20225beaf1.tar.gz
dexon-solidity-ed096881b97222357ac636b41eb21e20225beaf1.tar.bz2
dexon-solidity-ed096881b97222357ac636b41eb21e20225beaf1.tar.lz
dexon-solidity-ed096881b97222357ac636b41eb21e20225beaf1.tar.xz
dexon-solidity-ed096881b97222357ac636b41eb21e20225beaf1.tar.zst
dexon-solidity-ed096881b97222357ac636b41eb21e20225beaf1.zip
Use BUILD_SHARED_LIB
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b865d4af..d3f465f3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,11 +19,7 @@ set(EXECUTABLE lll)
file(GLOB HEADERS "*.h")
-if(ETH_STATIC)
- add_library(${EXECUTABLE} STATIC ${SRC_LIST} ${HEADERS})
-else()
- add_library(${EXECUTABLE} SHARED ${SRC_LIST} ${HEADERS})
-endif()
+add_library(${EXECUTABLE} ${SRC_LIST} ${HEADERS})
target_link_libraries(${EXECUTABLE} evmcore)
target_link_libraries(${EXECUTABLE} devcore)