aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristoph Jentzsch <jentzsch.software@gmail.com>2014-10-18 20:27:23 +0800
committerChristoph Jentzsch <jentzsch.software@gmail.com>2014-10-18 20:27:23 +0800
commit21457052fd6121dcb7ac7f79582fc2f2fb34f0d5 (patch)
tree521e1588a6c71431ee63b505005d9395d8c785d5 /CMakeLists.txt
parent1325b40ba5cc6a43ea05246f1c585be543a4bdd8 (diff)
parent693fe08bc996ff8403c75a770a735916dae4fc5b (diff)
downloaddexon-solidity-21457052fd6121dcb7ac7f79582fc2f2fb34f0d5.tar
dexon-solidity-21457052fd6121dcb7ac7f79582fc2f2fb34f0d5.tar.gz
dexon-solidity-21457052fd6121dcb7ac7f79582fc2f2fb34f0d5.tar.bz2
dexon-solidity-21457052fd6121dcb7ac7f79582fc2f2fb34f0d5.tar.lz
dexon-solidity-21457052fd6121dcb7ac7f79582fc2f2fb34f0d5.tar.xz
dexon-solidity-21457052fd6121dcb7ac7f79582fc2f2fb34f0d5.tar.zst
dexon-solidity-21457052fd6121dcb7ac7f79582fc2f2fb34f0d5.zip
Make all exceptions dervie virtual
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4dfd1b55..f031d0ee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,8 @@ include_directories(..)
link_directories(../libethcore)
link_directories(../libethereum)
-add_executable(testeth ${SRC_LIST})
+file(GLOB HEADERS "*.h")
+add_executable(testeth ${SRC_LIST} ${HEADERS})
add_executable(createRandomTest createRandomTest.cpp vm.cpp)
target_link_libraries(testeth ethereum)
@@ -22,7 +23,6 @@ target_link_libraries(createRandomTest boost_chrono)
target_link_libraries(createRandomTest boost_unit_test_framework)
-
if ("${TARGET_PLATFORM}" STREQUAL "w64")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -static-libgcc -static-libstdc++")
target_link_libraries(testeth boost_system-mt-s)