aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordebris <marek.kotewicz@gmail.com>2014-12-07 18:29:38 +0800
committerdebris <marek.kotewicz@gmail.com>2014-12-07 18:29:38 +0800
commitc7cf8c6db4b44842421a3fbabfaef84e1d745ca8 (patch)
tree9157f9efcdb653db3dd39929ceec4cbab3000c35 /CMakeLists.txt
parent2d8eaf84821ce8d46cc497af6271f59fb75a1b6c (diff)
downloaddexon-solidity-c7cf8c6db4b44842421a3fbabfaef84e1d745ca8.tar
dexon-solidity-c7cf8c6db4b44842421a3fbabfaef84e1d745ca8.tar.gz
dexon-solidity-c7cf8c6db4b44842421a3fbabfaef84e1d745ca8.tar.bz2
dexon-solidity-c7cf8c6db4b44842421a3fbabfaef84e1d745ca8.tar.lz
dexon-solidity-c7cf8c6db4b44842421a3fbabfaef84e1d745ca8.tar.xz
dexon-solidity-c7cf8c6db4b44842421a3fbabfaef84e1d745ca8.tar.zst
dexon-solidity-c7cf8c6db4b44842421a3fbabfaef84e1d745ca8.zip
solidity compiling under msvc && boosts cmake file fixed
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0f2dbbcd..895b22ae 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,7 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DSTATICLIB")
aux_source_directory(. SRC_LIST)
include_directories(${Boost_INCLUDE_DIRS})
+include_directories(${JSONCPP_INCLUDE_DIRS})
include_directories(..)
set(EXECUTABLE solidity)
@@ -17,11 +18,9 @@ else()
add_library(${EXECUTABLE} SHARED ${SRC_LIST} ${HEADERS})
endif()
-target_link_libraries(${EXECUTABLE} evmcore devcore)
-# TODO: Temporary until PR 532 https://github.com/ethereum/cpp-ethereum/pull/532
-# gets accepted. Then we can simply add jsoncpp as a dependency and not the
-# whole of JSONRPC as we are doing right here
-target_link_libraries(${EXECUTABLE} ${JSONRPC_LS})
+target_link_libraries(${EXECUTABLE} evmcore)
+target_link_libraries(${EXECUTABLE} devcore)
+target_link_libraries(${EXECUTABLE} ${JSONCPP_LIBRARIES})
install( TARGETS ${EXECUTABLE} ARCHIVE DESTINATION lib LIBRARY DESTINATION lib )
install( FILES ${HEADERS} DESTINATION include/${EXECUTABLE} )