aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsveneh <sven@ethdev.com>2014-11-20 17:55:36 +0800
committersveneh <sven@ethdev.com>2014-11-20 17:55:36 +0800
commit5c19ce88ff87bb672b445cc9fcfcf0e4234168f4 (patch)
treeae55375b547a0c72998efd6ee0a2cb29a2e9e243 /CMakeLists.txt
parent9be7f3c0307c66f7c58c4dc7eefcda9360ca29c0 (diff)
parent0eb527859fac01620f5d977726497ee8e9fd67e1 (diff)
downloaddexon-solidity-5c19ce88ff87bb672b445cc9fcfcf0e4234168f4.tar
dexon-solidity-5c19ce88ff87bb672b445cc9fcfcf0e4234168f4.tar.gz
dexon-solidity-5c19ce88ff87bb672b445cc9fcfcf0e4234168f4.tar.bz2
dexon-solidity-5c19ce88ff87bb672b445cc9fcfcf0e4234168f4.tar.lz
dexon-solidity-5c19ce88ff87bb672b445cc9fcfcf0e4234168f4.tar.xz
dexon-solidity-5c19ce88ff87bb672b445cc9fcfcf0e4234168f4.tar.zst
dexon-solidity-5c19ce88ff87bb672b445cc9fcfcf0e4234168f4.zip
Merge remote-tracking branch 'debris/mk_jsonrpc_upgrade' into build_enhancement
This basically pulls in libjson-rpc-cpp 0.3.2, updated from previous 0.2.1. v0.3.2 completely changes its own setup, hence such a massive change builds fine on Ubuntu, needs check on OS X Conflicts: CMakeLists.txt cmake/EthDependenciesDeprecated.cmake eth/CMakeLists.txt libqethereum/CMakeLists.txt libweb3jsonrpc/CMakeLists.txt neth/CMakeLists.txt test/CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c6da088b..fe0408a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,8 @@ aux_source_directory(. SRC_LIST)
list(REMOVE_ITEM SRC_LIST "./createRandomTest.cpp")
include_directories(..)
-include_directories(${CRYPTOPP_INCLUDE_DIR})
+include_directories(${CRYPTOPP_INCLUDE_DIRS})
+include_directories(${JSONCPP_INCLUDE_DIRS})
file(GLOB HEADERS "*.h")
add_executable(testeth ${SRC_LIST} ${HEADERS})
@@ -22,6 +23,7 @@ target_link_libraries(testeth webthree)
target_link_libraries(testeth ${CRYPTOPP_LIBRARIES})
if(JSON_RPC_CPP_FOUND)
+ target_link_libraries(testeth ${JSONCPP_LIBRARIES})
target_link_libraries(testeth web3jsonrpc)
endif()