Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | Change main file name from 0x.js.ts to 0x.ts | Leonid Logvinov | 2017-06-12 | 1 | -1/+1 |
| | |||||
* | Merge branch 'master' into chai-setup | Leonid | 2017-06-06 | 1 | -0/+11 |
|\ | |||||
| * | Address feedback | Leonid Logvinov | 2017-06-06 | 1 | -1/+2 |
| | | |||||
| * | Add regression test for transferFrom bug | Leonid Logvinov | 2017-06-05 | 1 | -0/+10 |
| | | |||||
* | | Address feedback | Leonid Logvinov | 2017-06-06 | 1 | -2/+2 |
| | | |||||
* | | Add chai_setup | Leonid Logvinov | 2017-06-05 | 1 | -1/+2 |
|/ | |||||
* | Fix bug | Fabio Berger | 2017-06-03 | 1 | -7/+5 |
| | |||||
* | Merge branch 'master' into remainingTokenMethods | Fabio Berger | 2017-06-03 | 1 | -0/+1 |
|\ | | | | | | | | | | | # Conflicts: # src/types.ts # src/web3_wrapper.ts | ||||
| * | Add includeStack config to chai setup so that we get stackTraces | Fabio Berger | 2017-06-03 | 1 | -0/+1 |
| | | |||||
* | | remove unneeded calls to toBaseUnitAmount | Fabio Berger | 2017-06-02 | 1 | -8/+4 |
| | | |||||
* | | pass numbers to BigNumber unless it's too big for the number type | Fabio Berger | 2017-06-02 | 1 | -4/+4 |
| | | |||||
* | | use BigNumber(0) instead of with a string zero | Fabio Berger | 2017-06-02 | 1 | -4/+4 |
| | | |||||
* | | Add balance check to `transferAsync` and related test | Fabio Berger | 2017-06-02 | 1 | -3/+14 |
| | | |||||
* | | Add tests for transferFromAsync, setAllowanceAsync and getAllowanceAsync and ↵ | Fabio Berger | 2017-06-02 | 1 | -21/+125 |
|/ | | | | fix up other test issues | ||||
* | Address feedback | Leonid Logvinov | 2017-05-31 | 1 | -26/+28 |
| | |||||
* | Add transfer function and tests for it | Leonid Logvinov | 2017-05-31 | 1 | -0/+19 |
| | |||||
* | remove unused imports | Fabio Berger | 2017-05-30 | 1 | -2/+0 |
| | |||||
* | Add test for setProxyAllowanceAsync and additional test for ↵ | Fabio Berger | 2017-05-30 | 1 | -2/+32 |
| | | | | getProxyAllowanceAsync | ||||
* | remove spaces after it keyword | Fabio Berger | 2017-05-30 | 1 | -2/+2 |
| | |||||
* | Add first test for getProxyAllowanceAsync | Fabio Berger | 2017-05-30 | 1 | -0/+9 |
| | |||||
* | use token instead of erc20 | Fabio Berger | 2017-05-30 | 1 | -3/+3 |
| | |||||
* | rename erc20Wrapper to tokenWrapper to be more generic in case we end up ↵ | Fabio Berger | 2017-05-30 | 1 | -0/+55 |
supporting another spec |