aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/order_utils/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'python-packages/order_utils/setup.py')
-rwxr-xr-xpython-packages/order_utils/setup.py11
1 files changed, 6 insertions, 5 deletions
diff --git a/python-packages/order_utils/setup.py b/python-packages/order_utils/setup.py
index 06533e60a..01a6c7360 100755
--- a/python-packages/order_utils/setup.py
+++ b/python-packages/order_utils/setup.py
@@ -21,7 +21,7 @@ class TestCommandExtension(TestCommand):
"""Invoke pytest."""
import pytest
- exit(pytest.main())
+ exit(pytest.main(["--doctest-modules"]))
class LintCommand(distutils.command.build_py.build_py):
@@ -165,9 +165,13 @@ setup(
"ganache": GanacheCommand,
},
install_requires=[
+ "0x-contract-addresses",
+ "0x-contract-artifacts",
"0x-json-schemas",
"eth-abi",
"eth_utils",
+ "hypothesis>=3.31.2", # HACK! this is web3's dependency!
+ # above works around https://github.com/ethereum/web3.py/issues/1179
"mypy_extensions",
"web3",
],
@@ -189,10 +193,7 @@ setup(
]
},
python_requires=">=3.6, <4",
- package_data={
- "zero_ex.order_utils": ["py.typed"],
- "zero_ex.contract_artifacts": ["artifacts/*"],
- },
+ package_data={"zero_ex.order_utils": ["py.typed"]},
package_dir={"": "src"},
license="Apache 2.0",
keywords=(