aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/order_utils/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'python-packages/order_utils/README.md')
-rw-r--r--python-packages/order_utils/README.md45
1 files changed, 45 insertions, 0 deletions
diff --git a/python-packages/order_utils/README.md b/python-packages/order_utils/README.md
new file mode 100644
index 000000000..a266694db
--- /dev/null
+++ b/python-packages/order_utils/README.md
@@ -0,0 +1,45 @@
+## 0x-order-utils
+
+0x order-related utilities for those developing on top of 0x protocol.
+
+Read the [documentation](https://0x.readthedocs.io/projects/order-utils/en/latest/)
+
+## Installing
+
+```bash
+pip install 0x-order-utils
+```
+
+## Contributing
+
+We welcome improvements and fixes from the wider community! To report bugs within this package, please create an issue in this repository.
+
+Please read our [contribution guidelines](../../CONTRIBUTING.md) before getting started.
+
+### Install Code and Dependencies
+
+Ensure that you have Python >=3.6 installed, then:
+
+```bash
+pip install -e .[dev]
+```
+
+### Test
+
+`./setup.py test`
+
+### Clean
+
+`./setup.py clean --all`
+
+### Lint
+
+`./setup.py lint`
+
+### Build Documentation
+
+`./setup.py build_sphinx`
+
+### More
+
+See `./setup.py --help-commands` for more info.