aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/sra_client/setup.py
diff options
context:
space:
mode:
authorHsuan Lee <hsuan@cobinhood.com>2019-01-19 18:42:04 +0800
committerHsuan Lee <hsuan@cobinhood.com>2019-01-19 18:42:04 +0800
commit7ae38906926dc09bc10670c361af0d2bf0050426 (patch)
tree5fb10ae366b987db09e4ddb4bc3ba0f75404ad08 /python-packages/sra_client/setup.py
parentb5fd3c72a08aaa6957917d74c333387a16edf66b (diff)
downloaddexon-sol-tools-7ae38906926dc09bc10670c361af0d2bf0050426.tar
dexon-sol-tools-7ae38906926dc09bc10670c361af0d2bf0050426.tar.gz
dexon-sol-tools-7ae38906926dc09bc10670c361af0d2bf0050426.tar.bz2
dexon-sol-tools-7ae38906926dc09bc10670c361af0d2bf0050426.tar.lz
dexon-sol-tools-7ae38906926dc09bc10670c361af0d2bf0050426.tar.xz
dexon-sol-tools-7ae38906926dc09bc10670c361af0d2bf0050426.tar.zst
dexon-sol-tools-7ae38906926dc09bc10670c361af0d2bf0050426.zip
Update dependency packages
Diffstat (limited to 'python-packages/sra_client/setup.py')
-rwxr-xr-xpython-packages/sra_client/setup.py77
1 files changed, 0 insertions, 77 deletions
diff --git a/python-packages/sra_client/setup.py b/python-packages/sra_client/setup.py
deleted file mode 100755
index 0921149bd..000000000
--- a/python-packages/sra_client/setup.py
+++ /dev/null
@@ -1,77 +0,0 @@
-#!/usr/bin/env python
-# coding: utf-8
-
-
-import subprocess
-import distutils.command.build_py
-
-from setuptools import setup, find_packages # noqa: H301
-
-NAME = "0x-sra-client"
-VERSION = "1.0.0"
-# To install the library, run the following
-#
-# python setup.py install
-#
-# prerequisite: setuptools
-# http://pypi.python.org/pypi/setuptools
-
-with open("README.md", "r") as file_handle:
- README_MD = file_handle.read()
-
-REQUIRES = ["urllib3 >= 1.15", "six >= 1.10", "certifi", "python-dateutil"]
-
-class TestPublishCommand(distutils.command.build_py.build_py):
- """Custom command to publish to test.pypi.org."""
-
- description = (
- "Publish dist/* to test.pypi.org. Run sdist & bdist_wheel first."
- )
-
- def run(self):
- """Run twine to upload to test.pypi.org."""
- subprocess.check_call( # nosec
- (
- "twine upload --repository-url https://test.pypi.org/legacy/"
- + " --verbose dist/*"
- ).split()
- )
-
-
-class PublishCommand(distutils.command.build_py.build_py):
- """Custom command to publish to pypi.org."""
-
- description = "Publish dist/* to pypi.org. Run sdist & bdist_wheel first."
-
- def run(self):
- """Run twine to upload to pypi.org."""
- subprocess.check_call("twine upload dist/*".split()) # nosec
-
-
-class LintCommand(distutils.command.build_py.build_py):
- """No-op lint command to support top-level lint script."""
-
- description = "No-op"
-
- def run(self):
- pass
-
-
-setup(
- name=NAME,
- version=VERSION,
- description="Standard Relayer REST API",
- author_email="",
- url="https://github.com/0xproject/0x-monorepo/python-packages/sra_client",
- keywords=["OpenAPI", "OpenAPI-Generator", "Standard Relayer REST API"],
- install_requires=REQUIRES,
- packages=find_packages(),
- include_package_data=True,
- long_description=README_MD,
- long_description_content_type="text/markdown",
- cmdclass={
- "test_publish": TestPublishCommand,
- "publish": PublishCommand,
- "lint": LintCommand,
- },
-)