aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/order_utils
diff options
context:
space:
mode:
authorBrandon Millman <brandon.millman@gmail.com>2018-11-20 01:32:39 +0800
committerBrandon Millman <brandon.millman@gmail.com>2018-11-20 01:32:39 +0800
commit3d6711bd38c3cb801d00a73a6386c4bb16359811 (patch)
tree411ffc816f673c69d50fcf0a9f0ae3c4defa4ea9 /python-packages/order_utils
parent004e197863e4df942d21f9e4ed629c08eeadad56 (diff)
parent99541f89f7676f6b0d8a923ad377fa901a74f504 (diff)
downloaddexon-sol-tools-3d6711bd38c3cb801d00a73a6386c4bb16359811.tar
dexon-sol-tools-3d6711bd38c3cb801d00a73a6386c4bb16359811.tar.gz
dexon-sol-tools-3d6711bd38c3cb801d00a73a6386c4bb16359811.tar.bz2
dexon-sol-tools-3d6711bd38c3cb801d00a73a6386c4bb16359811.tar.lz
dexon-sol-tools-3d6711bd38c3cb801d00a73a6386c4bb16359811.tar.xz
dexon-sol-tools-3d6711bd38c3cb801d00a73a6386c4bb16359811.tar.zst
dexon-sol-tools-3d6711bd38c3cb801d00a73a6386c4bb16359811.zip
Merge branch 'development' into feature/instant/icons
* development: (37 commits) Add 0x-order-utils.py library to developers home Fixes to CONTRIBUTING.md Improve our CONTRIBUTING.md instructions fix(order_utils.py): publish docs to S3, not RTD (#1264) fix: make instant package private feat: refer to map file in postpublish configs feat: add new bundle name to bundle watch fix: tslint ignore rule in wrong place Update blog post feature Fix disclaimer on mobile Add smart contract docs to Developer Home Add Apache license link Fix capitalization in title Remove excess semi-colon Point directly to README for docs link Update icons Update LICENSE Fix disclaimer Add blogpost URL Add disclaimer ...
Diffstat (limited to 'python-packages/order_utils')
-rw-r--r--python-packages/order_utils/.discharge.json13
-rw-r--r--python-packages/order_utils/README.md2
-rwxr-xr-xpython-packages/order_utils/setup.py16
3 files changed, 29 insertions, 2 deletions
diff --git a/python-packages/order_utils/.discharge.json b/python-packages/order_utils/.discharge.json
new file mode 100644
index 000000000..2b14aa023
--- /dev/null
+++ b/python-packages/order_utils/.discharge.json
@@ -0,0 +1,13 @@
+{
+ "domain": "0x-order-utils-py",
+ "build_command": "python setup.py build_sphinx",
+ "upload_directory": "build/docs/html",
+ "index_key": "index.html",
+ "error_key": "index.html",
+ "trailing_slashes": true,
+ "cache": 3600,
+ "aws_profile": "default",
+ "aws_region": "us-east-1",
+ "cdn": false,
+ "dns_configured": true
+}
diff --git a/python-packages/order_utils/README.md b/python-packages/order_utils/README.md
index 4c5f7627c..2181c7a11 100644
--- a/python-packages/order_utils/README.md
+++ b/python-packages/order_utils/README.md
@@ -2,7 +2,7 @@
0x order-related utilities for those developing on top of 0x protocol.
-Read the [documentation](https://0x.readthedocs.io/projects/order-utils/en/latest/)
+Read the [documentation](http://0x-order-utils-py.s3-website-us-east-1.amazonaws.com/)
## Installing
diff --git a/python-packages/order_utils/setup.py b/python-packages/order_utils/setup.py
index 679bfb4b2..125de5ff7 100755
--- a/python-packages/order_utils/setup.py
+++ b/python-packages/order_utils/setup.py
@@ -116,6 +116,19 @@ class PublishCommand(distutils.command.build_py.build_py):
subprocess.check_call("twine upload dist/*".split()) # nosec
+class PublishDocsCommand(distutils.command.build_py.build_py):
+ """Custom command to publish docs to S3."""
+
+ description = (
+ "Publish docs to "
+ + "http://0x-order-utils-py.s3-website-us-east-1.amazonaws.com/"
+ )
+
+ def run(self):
+ """Run npm package `discharge` to build & upload docs."""
+ subprocess.check_call("discharge deploy".split()) # nosec
+
+
class GanacheCommand(distutils.command.build_py.build_py):
"""Custom command to publish to pypi.org."""
@@ -141,7 +154,7 @@ with open("README.md", "r") as file_handle:
setup(
name="0x-order-utils",
- version="0.1.0",
+ version="1.0.1",
description="Order utilities for 0x applications",
long_description=README_MD,
long_description_content_type="text/markdown",
@@ -154,6 +167,7 @@ setup(
"test": TestCommandExtension,
"test_publish": TestPublishCommand,
"publish": PublishCommand,
+ "publish_docs": PublishDocsCommand,
"ganache": GanacheCommand,
},
install_requires=[