aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/order_utils/tox.ini
diff options
context:
space:
mode:
authorFabio Berger <me@fabioberger.com>2018-10-16 23:59:02 +0800
committerFabio Berger <me@fabioberger.com>2018-10-16 23:59:02 +0800
commitc84c92663d1ce0227b755dc861f825c35a3c7999 (patch)
tree3800297ba0072233fe88839b675e33e6b44f9649 /python-packages/order_utils/tox.ini
parent55a3bc8cb6772802672f60f22c5ed5c7e1b2dfdd (diff)
parentc333d093b585fa0250a6973f2d396eb3cf227334 (diff)
downloaddexon-sol-tools-c84c92663d1ce0227b755dc861f825c35a3c7999.tar
dexon-sol-tools-c84c92663d1ce0227b755dc861f825c35a3c7999.tar.gz
dexon-sol-tools-c84c92663d1ce0227b755dc861f825c35a3c7999.tar.bz2
dexon-sol-tools-c84c92663d1ce0227b755dc861f825c35a3c7999.tar.lz
dexon-sol-tools-c84c92663d1ce0227b755dc861f825c35a3c7999.tar.xz
dexon-sol-tools-c84c92663d1ce0227b755dc861f825c35a3c7999.tar.zst
dexon-sol-tools-c84c92663d1ce0227b755dc861f825c35a3c7999.zip
Merge branch 'dev-section-redesign' into reSkinReferenceDocs
* dev-section-redesign: (87 commits) Added note about restriction on `testDirectory` fix(dev-utils): Make chai a dev dependency since exported interface depends on it Add changelog entries fix(subproviders): make web3-provider-engine types a 'dependency' so it's available to users of the library fix(sra-spec): make @loopback/openapi-v3-types a 'dependency' so it's available to users of the library fix(sol-cov): make @types/solidity-parser-antlr a 'dependency' so it's available to users of the library fix(dev-utils): make web3-provider-engine types a 'dependency' so it's available to users of the library fix(0x.js): make web3-provider-engine types a 'dependency' so it's available to users of the library fix(monorepo-scripts): Move the creation of the `.installation-test` directory OUTSIDE of the monorepo root, so that the installed packages can't reference the hoisted node_modules folder Remove ContractNotFound errors in contract-wrappers Update prettierignore Update website to use the new unsubscribeAll method in contract-wrappers In abi-gen-wrappers, ./wrappers -> ./src/generated-wrappers In contract-wrappers, remove setProvider and add unsubscribeAll method. take out explicit children definition in props Update json-schemas for contract-wrappers Add OrThrow suffix to getContractAddressesForNetwork remove unused import Update CHANGELOG.json for all changed packages Remove ContractAddresses from packages/types (mistake after rebase) ...
Diffstat (limited to 'python-packages/order_utils/tox.ini')
-rw-r--r--python-packages/order_utils/tox.ini12
1 files changed, 12 insertions, 0 deletions
diff --git a/python-packages/order_utils/tox.ini b/python-packages/order_utils/tox.ini
new file mode 100644
index 000000000..1cce32b5f
--- /dev/null
+++ b/python-packages/order_utils/tox.ini
@@ -0,0 +1,12 @@
+# tox (https://tox.readthedocs.io/) is a tool for running tests
+# in multiple virtualenvs. This configuration file will run the
+# test suite on all supported python versions. To use it, "pip install tox"
+# and then run "tox" from this directory.
+
+[tox]
+envlist = py37
+
+[testenv]
+commands =
+ pip install -e .[dev]
+ python setup.py test