aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/order_utils/tox.ini
diff options
context:
space:
mode:
authorF. Eugene Aumson <feuGeneA@users.noreply.github.com>2018-10-27 02:27:57 +0800
committerGitHub <noreply@github.com>2018-10-27 02:27:57 +0800
commit0f6307169604f36b0316f236eb96d6001b788f50 (patch)
treee26e727f09246ff7c1b5d0e39074caef3fc8d0ce /python-packages/order_utils/tox.ini
parent4c5b26db183f8f9163e043f5dd4bb0ce60e3aa7f (diff)
downloaddexon-sol-tools-0f6307169604f36b0316f236eb96d6001b788f50.tar
dexon-sol-tools-0f6307169604f36b0316f236eb96d6001b788f50.tar.gz
dexon-sol-tools-0f6307169604f36b0316f236eb96d6001b788f50.tar.bz2
dexon-sol-tools-0f6307169604f36b0316f236eb96d6001b788f50.tar.lz
dexon-sol-tools-0f6307169604f36b0316f236eb96d6001b788f50.tar.xz
dexon-sol-tools-0f6307169604f36b0316f236eb96d6001b788f50.tar.zst
dexon-sol-tools-0f6307169604f36b0316f236eb96d6001b788f50.zip
fix(order_utils.py): tweaks for first publish (#1185)
Diffstat (limited to 'python-packages/order_utils/tox.ini')
-rw-r--r--python-packages/order_utils/tox.ini13
1 files changed, 13 insertions, 0 deletions
diff --git a/python-packages/order_utils/tox.ini b/python-packages/order_utils/tox.ini
index 1cce32b5f..ba7d55b56 100644
--- a/python-packages/order_utils/tox.ini
+++ b/python-packages/order_utils/tox.ini
@@ -10,3 +10,16 @@ envlist = py37
commands =
pip install -e .[dev]
python setup.py test
+
+[testenv:run_tests_against_test_deployment]
+commands =
+ # install dependencies from real PyPI
+ pip install eth-abi mypy_extensions web3 pytest
+ # install package-under-test from test PyPI
+ pip install --index-url https://test.pypi.org/legacy/ 0x-order-utils
+ pytest test
+
+[testenv:run_tests_against_deployment]
+commands =
+ pip install 0x-order-utils
+ pytest test