aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/order_utils/setup.py
diff options
context:
space:
mode:
authorAugust Skare <post@augustskare.no>2018-11-16 18:28:24 +0800
committerAugust Skare <post@augustskare.no>2018-11-16 18:28:24 +0800
commitc08108144825c33d8db26053c1d2d41460b09359 (patch)
tree6f21ce1e6834e0130b0f6063a097014cc1cc671f /python-packages/order_utils/setup.py
parent54bd7df900316504e4403bc94cffd92930a6c763 (diff)
parentcabb7432b9a6d4a5bb8da6fc7fe4522d24e4ece5 (diff)
downloaddexon-sol-tools-c08108144825c33d8db26053c1d2d41460b09359.tar
dexon-sol-tools-c08108144825c33d8db26053c1d2d41460b09359.tar.gz
dexon-sol-tools-c08108144825c33d8db26053c1d2d41460b09359.tar.bz2
dexon-sol-tools-c08108144825c33d8db26053c1d2d41460b09359.tar.lz
dexon-sol-tools-c08108144825c33d8db26053c1d2d41460b09359.tar.xz
dexon-sol-tools-c08108144825c33d8db26053c1d2d41460b09359.tar.zst
dexon-sol-tools-c08108144825c33d8db26053c1d2d41460b09359.zip
Merge branch 'development' into dev-tools-pages
Diffstat (limited to 'python-packages/order_utils/setup.py')
-rwxr-xr-xpython-packages/order_utils/setup.py13
1 files changed, 8 insertions, 5 deletions
diff --git a/python-packages/order_utils/setup.py b/python-packages/order_utils/setup.py
index 1b07b612c..679bfb4b2 100755
--- a/python-packages/order_utils/setup.py
+++ b/python-packages/order_utils/setup.py
@@ -24,7 +24,6 @@ class TestCommandExtension(TestCommand):
exit(pytest.main())
-# pylint: disable=too-many-ancestors
class LintCommand(distutils.command.build_py.build_py):
"""Custom setuptools command class for running linters."""
@@ -90,7 +89,6 @@ class CleanCommandExtension(clean):
rmtree("src/0x_order_utils.egg-info", ignore_errors=True)
-# pylint: disable=too-many-ancestors
class TestPublishCommand(distutils.command.build_py.build_py):
"""Custom command to publish to test.pypi.org."""
@@ -108,7 +106,6 @@ class TestPublishCommand(distutils.command.build_py.build_py):
)
-# pylint: disable=too-many-ancestors
class PublishCommand(distutils.command.build_py.build_py):
"""Custom command to publish to pypi.org."""
@@ -119,7 +116,6 @@ class PublishCommand(distutils.command.build_py.build_py):
subprocess.check_call("twine upload dist/*".split()) # nosec
-# pylint: disable=too-many-ancestors
class GanacheCommand(distutils.command.build_py.build_py):
"""Custom command to publish to pypi.org."""
@@ -160,7 +156,13 @@ setup(
"publish": PublishCommand,
"ganache": GanacheCommand,
},
- install_requires=["eth-abi", "eth_utils", "mypy_extensions", "web3"],
+ install_requires=[
+ "eth-abi",
+ "eth_utils",
+ "jsonschema",
+ "mypy_extensions",
+ "web3",
+ ],
extras_require={
"dev": [
"bandit",
@@ -182,6 +184,7 @@ setup(
package_data={
"zero_ex.order_utils": ["py.typed"],
"zero_ex.contract_artifacts": ["artifacts/*"],
+ "zero_ex.json_schemas": ["schemas/*"],
},
package_dir={"": "src"},
license="Apache 2.0",