aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/order_utils/setup.py
diff options
context:
space:
mode:
authorF. Eugene Aumson <feuGeneA@users.noreply.github.com>2018-11-14 23:41:52 +0800
committerGitHub <noreply@github.com>2018-11-14 23:41:52 +0800
commite1d64def2017ced0aba599b989ad42a51fdd46fe (patch)
tree3f1a0c101c6486998ffbc96e082f9772fad93f82 /python-packages/order_utils/setup.py
parentfe1b7f15e8531615a54e46581cb734e635d3c755 (diff)
downloaddexon-sol-tools-e1d64def2017ced0aba599b989ad42a51fdd46fe.tar
dexon-sol-tools-e1d64def2017ced0aba599b989ad42a51fdd46fe.tar.gz
dexon-sol-tools-e1d64def2017ced0aba599b989ad42a51fdd46fe.tar.bz2
dexon-sol-tools-e1d64def2017ced0aba599b989ad42a51fdd46fe.tar.lz
dexon-sol-tools-e1d64def2017ced0aba599b989ad42a51fdd46fe.tar.xz
dexon-sol-tools-e1d64def2017ced0aba599b989ad42a51fdd46fe.tar.zst
dexon-sol-tools-e1d64def2017ced0aba599b989ad42a51fdd46fe.zip
feat(order_utils.py): sign_hash() (#1254)
Also moved is_valid_signature() into main package module, for simplicity. Also consolidated a handul of in-line pylint disable directives into the .pylintrc config file.
Diffstat (limited to 'python-packages/order_utils/setup.py')
-rwxr-xr-xpython-packages/order_utils/setup.py4
1 files changed, 0 insertions, 4 deletions
diff --git a/python-packages/order_utils/setup.py b/python-packages/order_utils/setup.py
index 7f1da2f34..5a8db2b64 100755
--- a/python-packages/order_utils/setup.py
+++ b/python-packages/order_utils/setup.py
@@ -24,7 +24,6 @@ class TestCommandExtension(TestCommand):
exit(pytest.main())
-# pylint: disable=too-many-ancestors
class LintCommand(distutils.command.build_py.build_py):
"""Custom setuptools command class for running linters."""
@@ -90,7 +89,6 @@ class CleanCommandExtension(clean):
rmtree("src/0x_order_utils.egg-info", ignore_errors=True)
-# pylint: disable=too-many-ancestors
class TestPublishCommand(distutils.command.build_py.build_py):
"""Custom command to publish to test.pypi.org."""
@@ -108,7 +106,6 @@ class TestPublishCommand(distutils.command.build_py.build_py):
)
-# pylint: disable=too-many-ancestors
class PublishCommand(distutils.command.build_py.build_py):
"""Custom command to publish to pypi.org."""
@@ -119,7 +116,6 @@ class PublishCommand(distutils.command.build_py.build_py):
subprocess.check_call("twine upload dist/*".split()) # nosec
-# pylint: disable=too-many-ancestors
class GanacheCommand(distutils.command.build_py.build_py):
"""Custom command to publish to pypi.org."""