aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/order_utils/package.json
diff options
context:
space:
mode:
authorF. Eugene Aumson <feuGeneA@users.noreply.github.com>2018-10-11 00:14:20 +0800
committerF. Eugene Aumson <feuGeneA@users.noreply.github.com>2018-10-13 03:31:19 +0800
commit92fd0a9d24378d01d87dfa6fd0ec5a42edfe8308 (patch)
tree0f3f9a79e140748775f01af7e8b87bd36f497ed7 /python-packages/order_utils/package.json
parentf3cba233ad84b1c8191e91f35b72faa6a64078fa (diff)
downloaddexon-sol-tools-92fd0a9d24378d01d87dfa6fd0ec5a42edfe8308.tar
dexon-sol-tools-92fd0a9d24378d01d87dfa6fd0ec5a42edfe8308.tar.gz
dexon-sol-tools-92fd0a9d24378d01d87dfa6fd0ec5a42edfe8308.tar.bz2
dexon-sol-tools-92fd0a9d24378d01d87dfa6fd0ec5a42edfe8308.tar.lz
dexon-sol-tools-92fd0a9d24378d01d87dfa6fd0ec5a42edfe8308.tar.xz
dexon-sol-tools-92fd0a9d24378d01d87dfa6fd0ec5a42edfe8308.tar.zst
dexon-sol-tools-92fd0a9d24378d01d87dfa6fd0ec5a42edfe8308.zip
feat: project stub for python order utilities
An empty project, with respect to functionality, but one configured with a test framework, linters, CI integration, etc. https://app.asana.com/0/836857747873847/839549782781239/f
Diffstat (limited to 'python-packages/order_utils/package.json')
-rw-r--r--python-packages/order_utils/package.json17
1 files changed, 17 insertions, 0 deletions
diff --git a/python-packages/order_utils/package.json b/python-packages/order_utils/package.json
new file mode 100644
index 000000000..125ca71e0
--- /dev/null
+++ b/python-packages/order_utils/package.json
@@ -0,0 +1,17 @@
+{
+ "comment": "this file exists as an entry point to building this project, specifically for humans that are familiar with yarn and already have it installed. this file is not used in any automation or CI.",
+ "scripts": {
+ "install": "pip install -e .[dev]",
+ "build": "python setup.py build && yarn build:docs",
+ "build:docs": "python setup.py build_sphinx && sphinx-apidoc -o build/docs/api src",
+ "test:comment": "test in local environment. to test in all environments, use test:all",
+ "test": "python setup.py test",
+ "test:all": "tox",
+ "test:coverage": "coverage run setup.py test && coveralls",
+ "lint": "python setup.py lint",
+ "clean": "python setup.py clean"
+ },
+ "dependencies:comment": "managed in setup.py",
+ "devDependencies:comment": "managed in setup.py",
+ "license": "Apache-2.0"
+}