aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/order_utils/package.json
diff options
context:
space:
mode:
authorFabio Berger <me@fabioberger.com>2018-10-16 23:58:24 +0800
committerFabio Berger <me@fabioberger.com>2018-10-16 23:58:24 +0800
commitc333d093b585fa0250a6973f2d396eb3cf227334 (patch)
treea00b3d77fb78c744ee0fee2b57ef25ce775b087d /python-packages/order_utils/package.json
parent1cfcc82ea9869e14c1a1b78e1376c89fdbeb91f4 (diff)
parent72f5719b3412da7840a7b85e4dce512ecbaece4d (diff)
downloaddexon-sol-tools-c333d093b585fa0250a6973f2d396eb3cf227334.tar
dexon-sol-tools-c333d093b585fa0250a6973f2d396eb3cf227334.tar.gz
dexon-sol-tools-c333d093b585fa0250a6973f2d396eb3cf227334.tar.bz2
dexon-sol-tools-c333d093b585fa0250a6973f2d396eb3cf227334.tar.lz
dexon-sol-tools-c333d093b585fa0250a6973f2d396eb3cf227334.tar.xz
dexon-sol-tools-c333d093b585fa0250a6973f2d396eb3cf227334.tar.zst
dexon-sol-tools-c333d093b585fa0250a6973f2d396eb3cf227334.zip
merge development
Diffstat (limited to 'python-packages/order_utils/package.json')
-rw-r--r--python-packages/order_utils/package.json17
1 files changed, 17 insertions, 0 deletions
diff --git a/python-packages/order_utils/package.json b/python-packages/order_utils/package.json
new file mode 100644
index 000000000..125ca71e0
--- /dev/null
+++ b/python-packages/order_utils/package.json
@@ -0,0 +1,17 @@
+{
+ "comment": "this file exists as an entry point to building this project, specifically for humans that are familiar with yarn and already have it installed. this file is not used in any automation or CI.",
+ "scripts": {
+ "install": "pip install -e .[dev]",
+ "build": "python setup.py build && yarn build:docs",
+ "build:docs": "python setup.py build_sphinx && sphinx-apidoc -o build/docs/api src",
+ "test:comment": "test in local environment. to test in all environments, use test:all",
+ "test": "python setup.py test",
+ "test:all": "tox",
+ "test:coverage": "coverage run setup.py test && coveralls",
+ "lint": "python setup.py lint",
+ "clean": "python setup.py clean"
+ },
+ "dependencies:comment": "managed in setup.py",
+ "devDependencies:comment": "managed in setup.py",
+ "license": "Apache-2.0"
+}