aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/order_utils/README.md
diff options
context:
space:
mode:
authorF. Eugene Aumson <feuGeneA@users.noreply.github.com>2018-11-08 00:20:46 +0800
committerGitHub <noreply@github.com>2018-11-08 00:20:46 +0800
commit95b2898b9c0898c7e2d98ee603bff0604bf2a829 (patch)
tree6ac589bc869b0e177b48e4a2ae545fc986b08cba /python-packages/order_utils/README.md
parent094f71066294d14bc1920e4d3ddf4e7705201d61 (diff)
downloaddexon-sol-tools-95b2898b9c0898c7e2d98ee603bff0604bf2a829.tar
dexon-sol-tools-95b2898b9c0898c7e2d98ee603bff0604bf2a829.tar.gz
dexon-sol-tools-95b2898b9c0898c7e2d98ee603bff0604bf2a829.tar.bz2
dexon-sol-tools-95b2898b9c0898c7e2d98ee603bff0604bf2a829.tar.lz
dexon-sol-tools-95b2898b9c0898c7e2d98ee603bff0604bf2a829.tar.xz
dexon-sol-tools-95b2898b9c0898c7e2d98ee603bff0604bf2a829.tar.zst
dexon-sol-tools-95b2898b9c0898c7e2d98ee603bff0604bf2a829.zip
[order_utils.py] is_signature_valid, via Exchange contract (#1216)
First support for signature validation, done via Exchange contract's isValidSignature() method.
Diffstat (limited to 'python-packages/order_utils/README.md')
-rw-r--r--python-packages/order_utils/README.md4
1 files changed, 2 insertions, 2 deletions
diff --git a/python-packages/order_utils/README.md b/python-packages/order_utils/README.md
index a266694db..4c5f7627c 100644
--- a/python-packages/order_utils/README.md
+++ b/python-packages/order_utils/README.md
@@ -18,7 +18,7 @@ Please read our [contribution guidelines](../../CONTRIBUTING.md) before getting
### Install Code and Dependencies
-Ensure that you have Python >=3.6 installed, then:
+Ensure that you have installed Python >=3.6 and Docker. Then:
```bash
pip install -e .[dev]
@@ -26,7 +26,7 @@ pip install -e .[dev]
### Test
-`./setup.py test`
+Tests depend on a running ganache instance with the 0x contracts deployed in it. For convenience, a docker container is provided that has ganache-cli and a snapshot containing the necessary contracts. A shortcut is provided to run that docker container: `./setup.py ganache`. With that running, the tests can be run with `./setup.py test`.
### Clean