aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/order_utils/README.md
diff options
context:
space:
mode:
authorF. Eugene Aumson <feuGeneA@users.noreply.github.com>2018-10-27 02:27:57 +0800
committerGitHub <noreply@github.com>2018-10-27 02:27:57 +0800
commit0f6307169604f36b0316f236eb96d6001b788f50 (patch)
treee26e727f09246ff7c1b5d0e39074caef3fc8d0ce /python-packages/order_utils/README.md
parent4c5b26db183f8f9163e043f5dd4bb0ce60e3aa7f (diff)
downloaddexon-sol-tools-0f6307169604f36b0316f236eb96d6001b788f50.tar
dexon-sol-tools-0f6307169604f36b0316f236eb96d6001b788f50.tar.gz
dexon-sol-tools-0f6307169604f36b0316f236eb96d6001b788f50.tar.bz2
dexon-sol-tools-0f6307169604f36b0316f236eb96d6001b788f50.tar.lz
dexon-sol-tools-0f6307169604f36b0316f236eb96d6001b788f50.tar.xz
dexon-sol-tools-0f6307169604f36b0316f236eb96d6001b788f50.tar.zst
dexon-sol-tools-0f6307169604f36b0316f236eb96d6001b788f50.zip
fix(order_utils.py): tweaks for first publish (#1185)
Diffstat (limited to 'python-packages/order_utils/README.md')
-rw-r--r--python-packages/order_utils/README.md45
1 files changed, 45 insertions, 0 deletions
diff --git a/python-packages/order_utils/README.md b/python-packages/order_utils/README.md
new file mode 100644
index 000000000..a266694db
--- /dev/null
+++ b/python-packages/order_utils/README.md
@@ -0,0 +1,45 @@
+## 0x-order-utils
+
+0x order-related utilities for those developing on top of 0x protocol.
+
+Read the [documentation](https://0x.readthedocs.io/projects/order-utils/en/latest/)
+
+## Installing
+
+```bash
+pip install 0x-order-utils
+```
+
+## Contributing
+
+We welcome improvements and fixes from the wider community! To report bugs within this package, please create an issue in this repository.
+
+Please read our [contribution guidelines](../../CONTRIBUTING.md) before getting started.
+
+### Install Code and Dependencies
+
+Ensure that you have Python >=3.6 installed, then:
+
+```bash
+pip install -e .[dev]
+```
+
+### Test
+
+`./setup.py test`
+
+### Clean
+
+`./setup.py clean --all`
+
+### Lint
+
+`./setup.py lint`
+
+### Build Documentation
+
+`./setup.py build_sphinx`
+
+### More
+
+See `./setup.py --help-commands` for more info.