aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/contract_demo/README.md
diff options
context:
space:
mode:
authorSteve Klebanoff <steve.klebanoff@gmail.com>2019-01-12 00:53:15 +0800
committerSteve Klebanoff <steve.klebanoff@gmail.com>2019-01-12 00:53:15 +0800
commitfaee7513952a4b87d5f9e9dde9deb20126f58834 (patch)
tree8168000e484e621e1526cf48fb0f979a6d98d972 /python-packages/contract_demo/README.md
parent742e5e039dd4e821209b5511fb6a194d11c6291c (diff)
parent2cf57a48dd2857dd5cf2f31f4c60dd47ae4d34a5 (diff)
downloaddexon-sol-tools-faee7513952a4b87d5f9e9dde9deb20126f58834.tar
dexon-sol-tools-faee7513952a4b87d5f9e9dde9deb20126f58834.tar.gz
dexon-sol-tools-faee7513952a4b87d5f9e9dde9deb20126f58834.tar.bz2
dexon-sol-tools-faee7513952a4b87d5f9e9dde9deb20126f58834.tar.lz
dexon-sol-tools-faee7513952a4b87d5f9e9dde9deb20126f58834.tar.xz
dexon-sol-tools-faee7513952a4b87d5f9e9dde9deb20126f58834.tar.zst
dexon-sol-tools-faee7513952a4b87d5f9e9dde9deb20126f58834.zip
Merge branch 'development' into feature/instant/asset-buyer-check-liquidity
Diffstat (limited to 'python-packages/contract_demo/README.md')
-rw-r--r--python-packages/contract_demo/README.md39
1 files changed, 39 insertions, 0 deletions
diff --git a/python-packages/contract_demo/README.md b/python-packages/contract_demo/README.md
new file mode 100644
index 000000000..3a0f964e3
--- /dev/null
+++ b/python-packages/contract_demo/README.md
@@ -0,0 +1,39 @@
+## 0x-contract-demo
+
+A demonstration of calling 0x smart contracts from Python.
+
+Read the [documentation](http://0x-contract-demo-py.s3-website-us-east-1.amazonaws.com/)
+
+## Contributing
+
+We welcome improvements and fixes from the wider community! To report bugs within this package, please create an issue in this repository.
+
+Please read our [contribution guidelines](../../CONTRIBUTING.md) before getting started.
+
+### Install Code and Dependencies
+
+Ensure that you have installed Python >=3.6 and Docker. Then:
+
+```bash
+pip install -e .[dev]
+```
+
+### Test
+
+Tests depend on a running ganache instance with the 0x contracts deployed in it. For convenience, a docker container is provided that has ganache-cli and a snapshot containing the necessary contracts. A shortcut is provided to run that docker container: `./setup.py ganache`. With that running, the tests can be run with `./setup.py test`.
+
+### Clean
+
+`./setup.py clean --all`
+
+### Lint
+
+`./setup.py lint`
+
+### Build Documentation
+
+`./setup.py build_sphinx`
+
+### More
+
+See `./setup.py --help-commands` for more info.