aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/order_utils/setup.py
diff options
context:
space:
mode:
authorF. Eugene Aumson <feuGeneA@users.noreply.github.com>2018-11-17 20:07:25 +0800
committerGitHub <noreply@github.com>2018-11-17 20:07:25 +0800
commit43443d6057da64e972511e3a79334407874d2084 (patch)
tree811ef884ed0e314574768da001b5a4359d884091 /python-packages/order_utils/setup.py
parent9914f7edefa96c564768233ab6a1f21b0835a49f (diff)
downloaddexon-0x-contracts-43443d6057da64e972511e3a79334407874d2084.tar
dexon-0x-contracts-43443d6057da64e972511e3a79334407874d2084.tar.gz
dexon-0x-contracts-43443d6057da64e972511e3a79334407874d2084.tar.bz2
dexon-0x-contracts-43443d6057da64e972511e3a79334407874d2084.tar.lz
dexon-0x-contracts-43443d6057da64e972511e3a79334407874d2084.tar.xz
dexon-0x-contracts-43443d6057da64e972511e3a79334407874d2084.tar.zst
dexon-0x-contracts-43443d6057da64e972511e3a79334407874d2084.zip
fix(order_utils.py): publish docs to S3, not RTD (#1264)
Publishing to readthedocs.io (RTD) wasn't working, for various reasons. Changed to publish docs to S3.
Diffstat (limited to 'python-packages/order_utils/setup.py')
-rwxr-xr-xpython-packages/order_utils/setup.py16
1 files changed, 15 insertions, 1 deletions
diff --git a/python-packages/order_utils/setup.py b/python-packages/order_utils/setup.py
index 679bfb4b2..125de5ff7 100755
--- a/python-packages/order_utils/setup.py
+++ b/python-packages/order_utils/setup.py
@@ -116,6 +116,19 @@ class PublishCommand(distutils.command.build_py.build_py):
subprocess.check_call("twine upload dist/*".split()) # nosec
+class PublishDocsCommand(distutils.command.build_py.build_py):
+ """Custom command to publish docs to S3."""
+
+ description = (
+ "Publish docs to "
+ + "http://0x-order-utils-py.s3-website-us-east-1.amazonaws.com/"
+ )
+
+ def run(self):
+ """Run npm package `discharge` to build & upload docs."""
+ subprocess.check_call("discharge deploy".split()) # nosec
+
+
class GanacheCommand(distutils.command.build_py.build_py):
"""Custom command to publish to pypi.org."""
@@ -141,7 +154,7 @@ with open("README.md", "r") as file_handle:
setup(
name="0x-order-utils",
- version="0.1.0",
+ version="1.0.1",
description="Order utilities for 0x applications",
long_description=README_MD,
long_description_content_type="text/markdown",
@@ -154,6 +167,7 @@ setup(
"test": TestCommandExtension,
"test_publish": TestPublishCommand,
"publish": PublishCommand,
+ "publish_docs": PublishDocsCommand,
"ganache": GanacheCommand,
},
install_requires=[